camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Updated] (CAMEL-4276) camel-cxf OSGi bundle uses an incorrect CXF version range
Date Thu, 28 Jul 2011 17:53:09 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-4276?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Baptiste Onofré updated CAMEL-4276:
----------------------------------------

    Fix Version/s: 2.8.1
                   2.7.4

> camel-cxf OSGi bundle uses an incorrect CXF version range
> ---------------------------------------------------------
>
>                 Key: CAMEL-4276
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4276
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-cxf
>    Affects Versions: 2.7.3, 2.8.0
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 2.7.4, 2.8.1, 2.9.0
>
>
> The camel-cxf Karaf feature defines the following CXF version range:
> <feature version="[2.4,2.6)">cxf</feature>
> which is correct.
> Unfortunately the camel-cxf bundle import statement doesn't define explicitly the CXF
version range. The Felix maven-bundle-plugin determines the version range with the CXF version
used and so define it to [2.4,2.5).
> 1/ it's not correct as it doesn't match the feature definition
> 2/ it means that you can't use Camel with CXF 2.5.0-SNAPSHOT

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message