camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (JIRA)" <>
Subject [jira] [Updated] (CAMEL-4047) javax.script dependency in camel-core
Date Mon, 06 Jun 2011 17:39:59 GMT


Daniel Kulp updated CAMEL-4047:

    Attachment: CAMEL-4047.patch

May need to use "git apply" to apply the patch due to the removal of a file.

I've tested a bit in a standalone OSGi container (TSF) installing the camel-script feature
and such.   However, I haven't been able to run the camel-ittest-osgi stuff yet due to them
being broken.

> javax.script dependency in camel-core
> -------------------------------------
>                 Key: CAMEL-4047
>                 URL:
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-core
>    Affects Versions: 2.8.0
>            Reporter: Daniel Kulp
>            Assignee: Daniel Kulp
>         Attachments: CAMEL-4047.patch
> The OSGi imports for camel-core ends up with a non-optional dependency on javax.script
due to it being used in the Activator.    However, the karaf feature for camel-core doesn't
have a dependency on org.apache.servicemix.specs.scripting-api-1.0 .
> One of two things should be done:
> 1) mark javax.script as optional.  This MAY require some updates to the Activator to
work when it's not available.
> 2) Update the karaf features file to add:
> {code:xml}
> <bundle dependency="true">mvn:org.apache.servicemix.specs/org.apache.servicemix.specs.scripting-api-1.0/${servicemix-specs-version}</bundle>
> {code}

This message is automatically generated by JIRA.
For more information on JIRA, see:

View raw message