camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <>
Subject [jira] [Commented] (CAMEL-3995) Avoid Camel feature linked to a specific Karaf version
Date Sat, 04 Jun 2011 09:27:47 GMT


Claus Ibsen commented on CAMEL-3995:

Jean the osgi tests uses pax-exam to setup and run the tests. So whatever changes you want
to introduce, it must be able to run the unit test without problems. 

Take a look at OSGiIntegrationTestSupport in the source code for tests/camel-itest-osgi.
And see if you can get that working with your patch.

> Avoid Camel feature linked to a specific Karaf version
> ------------------------------------------------------
>                 Key: CAMEL-3995
>                 URL:
>             Project: Camel
>          Issue Type: Improvement
>          Components: karaf
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 2.8.0
>         Attachments: CAMEL-3995.patch
> To be compatible with several Karaf versions (including minor release), Camel feature
shouldn't refer to a specific Karaf version.

This message is automatically generated by JIRA.
For more information on JIRA, see:

View raw message