camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johan Edstrom <seij...@gmail.com>
Subject Re: [PROPSAL] Release Camel 2.7.1
Date Mon, 04 Apr 2011 14:58:41 GMT
If cxf:endpoint is tested as is against 2.4.0-SNAPSHOT, i.e the spring code, we should be home-free.



On Apr 4, 2011, at 8:56 AM, Hadrian Zbarcea wrote:

> We need to make sure camel-cxf works with both 2.3.x and 2.4.x, correct?
> Hadrian
> 
> On Apr 4, 2011, at 10:49 AM, Johan Edstrom wrote:
> 
>> 2.4.3 will need some api changes on in/out interceptors.
>> Otherwise an upgrade is  pretty easy.
>> 
>> Also 2.4 is going to contain plenty more BP stuff.
>> That features file just started working 3 days ago.
>> 
>> On Apr 4, 2011, at 8:38 AM, Hadrian Zbarcea wrote:
>> 
>>> Christian, can we get some sort of commitment from the cxf community that cxf
2.4.x will be backwards compatible with 2.3.x? I saw that you made the following change on
trunk: 
>>> org.apache.cxf.*;version="[2.3.2,2.5)"
>>> 
>>> Are there any other dependencies we need to upgrade?
>>> 
>>> Hadrian
>>> 
>>> On Apr 4, 2011, at 10:32 AM, Christian Schneider wrote:
>>> 
>>>> Yes we need a new camel release to be compatible with cxf 2.4. The question
is only if we can also do something with the feature file to make it compatible with cxf 2.3
and 2.4.
>>>> 
>>>> Christian
>>>> 
>>>> 
>>>> Am 04.04.2011 16:24, schrieb Jean-Baptiste Onofré:
>>>>> Hi Christian,
>>>>> 
>>>>> I guess that the camel-cxf POM should be also updated to update the CXF
version range.
>>>>> So we need a new Camel release for that, no ?
>>>>> 
>>>>> Regards
>>>>> JB
>>>>> 
>>>>> On 04/04/2011 04:25 PM, Christian Schneider wrote:
>>>>>> What do we do with the karaf feature file?
>>>>>> The camel-cxf features are not suitable for cxf 2.4. On the other
hand
>>>>>> CXF 2.4 brings it´s own feature file. So if the cxf feature is installed
>>>>>> camel-cxf can just be installed.
>>>>>> 
>>>>>> Any ideas?
>>>>>> 
>>>>>> Christian
>>>>>> 
>>>>>> 
>>>>>> Am 04.04.2011 16:20, schrieb Hadrian Zbarcea:
>>>>>>> Hi,
>>>>>>> 
>>>>>>> There are a few dependencies that are used with camel that we
don't
>>>>>>> support as mentioned on the SMX mailing list and CAMEL-3830.
>>>>>>> 
>>>>>>> I think we should support at least:
>>>>>>> * slf4j 1.6.x
>>>>>>> * jetty 7.3.1.v20110307
>>>>>>> * cxf 2.4.x
>>>>>>> * (if you know of other dependencies that should be upgraded,
please
>>>>>>> comment)
>>>>>>> 
>>>>>>> ... and issue a camel-2.7.1 asap. Thoughts?
>>>>>>> 
>>>>>>> Hadrian
>>>>>> 
>>>>> 
>>>> 
>>>> -- 
>>>> ----
>>>> http://www.liquid-reality.de
>>>> 
>>> 
>> 
> 


Mime
View raw message