camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CAMEL-3881) camel-spring doesn't import into eclipse
Date Tue, 19 Apr 2011 21:05:05 GMT
camel-spring doesn't import into eclipse
----------------------------------------

                 Key: CAMEL-3881
                 URL: https://issues.apache.org/jira/browse/CAMEL-3881
             Project: Camel
          Issue Type: Bug
          Components: camel-spring
    Affects Versions: 2.8.0
            Reporter: Daniel Kulp



camel-spring no longer imports into eclipse as OsgiSpringCamelContext references OsgiTypeConverter
which implements ServiceTrackerCustomizer.   The org.osgi.compendium jar isn't a dependency
of camel-spring so the class cannot be found and eclipse gives an error.

Simple fix is to add a dependency to the pom:

{code:xml}
    <dependency>
      <groupId>org.osgi</groupId>
      <artifactId>org.osgi.compendium</artifactId>
      <scope>provided</scope>
      <optional>true</optional>
    </dependency>
{code}





--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message