camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadrian Zbarcea (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-3830) Camel 2.7.0 - unable to use sl4j 1.6.1
Date Mon, 04 Apr 2011 13:09:05 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-3830?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13015389#comment-13015389
] 

Hadrian Zbarcea commented on CAMEL-3830:
----------------------------------------

As the number of dependencies can quickly explode once you take into account different versions
of a dependency, which is next to impossible to test, we are a bit restrictive in Camel and
make the assumption that future minor versions of a project will stay backwards compatible,
but we don't necessarily assume that major versions will. In the slf4j case, for instance,
we'll be able to work with a 1.5.12 and we'll assume that version backwards compatible, but
not 1.6.x. So we may be a bit to conservative from that point of view.

That said, we'd identified other dependencies were we can relax this constraint a bit and
we'll discuss releasing an early 2.7.1 supporting slf4j 1.6.x

> Camel 2.7.0 - unable to use sl4j 1.6.1
> --------------------------------------
>
>                 Key: CAMEL-3830
>                 URL: https://issues.apache.org/jira/browse/CAMEL-3830
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-core
>    Affects Versions: 2.7.0
>         Environment: tomcat 7.0.11, windows 7 ultimate 64bit
>            Reporter: chee sang
>             Fix For: 2.8.0
>
>
> previously using camel 2.6.0 with sl4j 1.6.1 & spring integration 2.0 without any
issue. after compile & deployed with camel 2.7.0 using maven (by exclusion sl4j for camel
in pom) & double check no old version of sl4j jar was deployed into WEB-INF\lib. when
startup tomcat, give error "The requested version 1.6 by your slf4j binding is not compatible
with [1.5.5, 1.5.6, 1.5.7, 1.5.8, 1.5.9, 1.5.10, 1.5.11]" and my app was unable to deploy
successfully

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message