camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Willem Jiang (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (CAMEL-3763) Update Camel features descriptor to be Karaf 2.2.0 compliant
Date Tue, 15 Mar 2011 13:49:29 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-3763?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13006912#comment-13006912
] 

Willem Jiang edited comment on CAMEL-3763 at 3/15/11 1:48 PM:
--------------------------------------------------------------

I just added
{code}
<repository>mvn:org.apache.karaf.assemblies.features/standard/2.2.0/xml/features</repository>
{code}
into patched apache-camel features.xml and ran "mvn clean install -Pvalidate" in the features
directory.

I got a complain about the camel-blueprint, and there is no special feature entry in the karaf
2.2.0 to help me install blueprint bundles. I tried to add these bundles into camel-blueprint
feature (copying it from the karaf enterprise feature), then feature plugin complained about
it can't find asm package for org.apache.aries.proxy bundle.
{code}
     <bundle>mvn:org.apache.aries.blueprint/org.apache.aries.blueprint/0.3</bundle>
     <bundle>mvn:org.apache.aries.proxy/org.apache.aries.proxy/0.3</bundle>
     <bundle>mvn:org.apache.aries/org.apache.aries.util/0.3</bundle>
{code} 

JB, can you explain why you removed the org.apache.aries.blueprint bundle which is used by
camel-blueprint in the latest patch?


      was (Author: njiang):
    I just added 
<repository>mvn:org.apache.karaf.assemblies.features/standard/2.2.0/xml/features</repository>
into patched apache-camel features.xml and ran "mvn clean install -Pvalidate" in the features
directory.

I got a complain about the camel-blueprint, and there is no special feature entry in the karaf
2.2.0 to help me install blueprint bundles. I tried to add these bundles into camel-blueprint
feature (copying it from the karaf enterprise feature), then feature plugin complained about
it can't find asm package for org.apache.aries.proxy bundle.
{code}
     <bundle>mvn:org.apache.aries.blueprint/org.apache.aries.blueprint/0.3</bundle>
     <bundle>mvn:org.apache.aries.proxy/org.apache.aries.proxy/0.3</bundle>
     <bundle>mvn:org.apache.aries/org.apache.aries.util/0.3</bundle>
{code} 

JB, can you explain why you removed the org.apache.aries.blueprint bundle which is used by
camel-blueprint in the latest patch?

  
> Update Camel features descriptor to be Karaf 2.2.0 compliant
> ------------------------------------------------------------
>
>                 Key: CAMEL-3763
>                 URL: https://issues.apache.org/jira/browse/CAMEL-3763
>             Project: Camel
>          Issue Type: Task
>          Components: karaf
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Hadrian Zbarcea
>             Fix For: 2.8.0
>
>         Attachments: CAMEL-3763.patch, CAMEL-3763.patch
>
>
> To be compliant with Karaf 2.2.0, the Camel features descriptor will be update:
> - to avoid to override the Aries blueprint bundle
> - to not define Karaf external repository
> - to use the OBR resolver

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message