camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: [DISCUSS] Dropping support for java 1.5 from camel-2.7.0 onwards
Date Sat, 05 Feb 2011 08:08:19 GMT
On Sat, Feb 5, 2011 at 3:40 AM, Hadrian Zbarcea <hzbarcea@gmail.com> wrote:
> CAMEL-3603 is done. What's next? Dropping Junit 3?
>

That's great Hadrian.

There is a tiny bit Java code which can be migrated to Java 6, for
example IOException now accepts a nested exception so we dont need to
use IOHelper for that.


I think dropping JUnit 3 should be started with all the examples, componets etc.
I think we once tried to upgrade junit in camel-core and had some
subtle unit tests issues at that time.
Maybe thats resolved om java 6 with latest junit release. But I would
upgrade the core as last step.




> Hadrian
>
> On Feb 4, 2011, at 2:54 AM, Claus Ibsen wrote:
>
>> Hi
>>
>> Camel 2.7 roadmap
>> http://camel.apache.org/camel-27-roadmap.html
>>
>> The switching to slf4j logging is now complete on trunk.
>>
>> Are we ready for the next step? To drop JDK 1.5?
>> https://issues.apache.org/jira/browse/CAMEL-3603
>>
>>
>> When we get started on this, there is no turning back.
>>
>>
>>
>>
>> --
>> Claus Ibsen
>> -----------------
>> FuseSource
>> Email: cibsen@fusesource.com
>> Web: http://fusesource.com
>> Twitter: davsclaus
>> Blog: http://davsclaus.blogspot.com/
>> Author of Camel in Action: http://www.manning.com/ibsen/
>
>



-- 
Claus Ibsen
-----------------
FuseSource
Email: cibsen@fusesource.com
Web: http://fusesource.com
Twitter: davsclaus
Blog: http://davsclaus.blogspot.com/
Author of Camel in Action: http://www.manning.com/ibsen/

Mime
View raw message