camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: [DISCUSS] Dropping support for java 1.5 from camel-2.7.0 onwards
Date Mon, 24 Jan 2011 15:27:59 GMT
On Mon, Jan 24, 2011 at 4:22 PM, Christian Schneider
<cschneider@talend.com> wrote:
> +1 For all points.
>
> I only have a question about the switch to slf4j. Does this mean we should convert all
logging statements? Can this be automated?
>

Good question. Yes it can be automated. There is a tool for that:
http://www.slf4j.org/migrator.html

With the sfl4j API in camel-core we will then be able to start using MDC.

And the API has support for placeholders which makes it easier to use
for logging with parameters
http://www.slf4j.org/manual.html

And the Q about how not to log for best performance
http://www.slf4j.org/faq.html#logging_performance





> Christian
>
>
> -----Urspr√ľngliche Nachricht-----
> Von: Claus Ibsen [mailto:claus.ibsen@gmail.com]
> Gesendet: Montag, 24. Januar 2011 15:49
> An: dev@camel.apache.org
> Betreff: Re: [DISCUSS] Dropping support for java 1.5 from camel-2.7.0 onwards
>
> In light of this I would like to propose the idea of moving some of the todo's from the
Camel 3.0 roadmap into Camel 2.7, specifically:
> - switching to slf4j as logger
> - upgrading to jdk 1.6 as minimum
> - upgrading to spring 3.0 as minimum
>
>



-- 
Claus Ibsen
-----------------
FuseSource
Email: cibsen@fusesource.com
Web: http://fusesource.com
Twitter: davsclaus
Blog: http://davsclaus.blogspot.com/
Author of Camel in Action: http://www.manning.com/ibsen/

Mime
View raw message