camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: [DISCUSS] Dropping support for java 1.5 from camel-2.7.0 onwards
Date Mon, 24 Jan 2011 14:51:58 GMT
On Mon, Jan 24, 2011 at 3:29 PM, Hadrian Zbarcea <hzbarcea@gmail.com> wrote:
> Hi,
>
> Camel-2.6.0 is being build while I write this. One of the things that was informally
discussed and I am formally proposing now is dropping support for java 1.5 starting with the
next release. It hasn't been supported for a while and the survey showed almost no interest
in it.
>
> If needed (which I personally doubt), we could have 2.6.x releases on java 1.5. Other
Apache projects already dropped support for java 1.x on trunk as well.
>
> Thoughts?
>
> Hadrian

By upgrading to JDK 1.6 we can also start to include components which
uses libaries that requires JDK 1.6+. For example the Apache Cassandra
project. We have a camel-cassandra project at github which the author
is willing to donate to Apache Camel when we are ready to include it.

I am sure there are other of the new cloud and no-sql frameworks which
would be interesting to have a Camel story and components out of the
box.


-- 
Claus Ibsen
-----------------
FuseSource
Email: cibsen@fusesource.com
Web: http://fusesource.com
Twitter: davsclaus
Blog: http://davsclaus.blogspot.com/
Author of Camel in Action: http://www.manning.com/ibsen/

Mime
View raw message