camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: Building Camel with Maven 3
Date Fri, 21 Jan 2011 12:46:09 GMT
On Fri, Jan 21, 2011 at 1:38 PM, Christian Müller
<christian.mueller@gmail.com> wrote:
> Sure, I will wait until Camel 2.6 is out.
> I linked this thread to https://issues.apache.org/jira/browse/CAMEL-3268 and
> don't open a new JIRA for it.
> I hope I will find a solution which work with Maven 2.2 and Maven 3.
>

Perfect. Sometime we can upgrade the plugin version so they work with
both 2.2.x and 3.0, but not always.

And mind that Maven 3 is not always supported on the CI servers which
is often configured to use Maven 2.2.1.
And mind that there is a lot of different platforms to build as well.
Not just windows, mac and linux.

When using IBM AIX, HP-UX, Solaris and whatnot, those platforms often
have some sublet issues, with either the JDK or Maven version. So its
not always just that easy.



-- 
Claus Ibsen
-----------------
FuseSource
Email: cibsen@fusesource.com
Web: http://fusesource.com
Twitter: davsclaus
Blog: http://davsclaus.blogspot.com/
Author of Camel in Action: http://www.manning.com/ibsen/

Mime
View raw message