camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Willem Jiang (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CAMEL-3228) Dozer should support OSGi and work with Apache Camel
Date Thu, 13 Jan 2011 14:30:46 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-3228?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12981262#action_12981262
] 

Willem Jiang commented on CAMEL-3228:
-------------------------------------

@Dmitry,
Thanks for your contribution.
I just committed your patch with some change to get the OSGi integration test passed.
1. Using the classloader of DozerClassLoader as a fallback for LoadResource
2. Fixing the CamelContext.xml issue of OSGi DozerTest


> Dozer should support OSGi and work with Apache Camel
> ----------------------------------------------------
>
>                 Key: CAMEL-3228
>                 URL: https://issues.apache.org/jira/browse/CAMEL-3228
>             Project: Camel
>          Issue Type: Improvement
>            Reporter: Konstantin Buzdin
>            Assignee: Willem Jiang
>             Fix For: 2.6.0
>
>         Attachments: CAMEL-3228_-_Upgrade_to_Dozer_5_3_0_.patch, camel_class_loading_fix_.patch,
dozer-osgi-5.3.0.jar, pom.xml
>
>
> Dozer 5.3.0 has been released. It has changes in internal API, which make usage of dozer-camel
impossible with the most recent version.
> As Dozer maintainer I could contribute a patch upgrading camel-dozer module to use 5.3.0.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message