camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Buzdin (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CAMEL-3228) Dozer should support OSGi and work with Apache Camel
Date Thu, 13 Jan 2011 12:02:46 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-3228?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12981227#action_12981227
] 

Dmitry Buzdin commented on CAMEL-3228:
--------------------------------------

@Willem

I have attached a patch. Could you please test it. I have difficulties running osgi integration
tests. The idea is that DozerMapper instance is provided to DozerTypeConverterLoader and it
changes the internal behavior of class loading.
This should work with existing 5.3.1 version.

> Dozer should support OSGi and work with Apache Camel
> ----------------------------------------------------
>
>                 Key: CAMEL-3228
>                 URL: https://issues.apache.org/jira/browse/CAMEL-3228
>             Project: Camel
>          Issue Type: Improvement
>            Reporter: Konstantin Buzdin
>            Assignee: Willem Jiang
>             Fix For: 2.7.0
>
>         Attachments: CAMEL-3228_-_Upgrade_to_Dozer_5_3_0_.patch, camel_class_loading_fix_.patch,
dozer-osgi-5.3.0.jar, pom.xml
>
>
> Dozer 5.3.0 has been released. It has changes in internal API, which make usage of dozer-camel
impossible with the most recent version.
> As Dozer maintainer I could contribute a patch upgrading camel-dozer module to use 5.3.0.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message