camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Willem Jiang (JIRA)" <j...@apache.org>
Subject [jira] Updated: (CAMEL-3505) make the camel bundle work better with packages which exports from JRE
Date Thu, 06 Jan 2011 10:06:45 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-3505?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Willem Jiang updated CAMEL-3505:
--------------------------------


Just checked camel-jaxb, camel-cxf which use the packages shipped with JRE, they look good.
We just need to up the camel-soap for it.

> make the camel bundle work better with packages which exports from JRE
> ----------------------------------------------------------------------
>
>                 Key: CAMEL-3505
>                 URL: https://issues.apache.org/jira/browse/CAMEL-3505
>             Project: Camel
>          Issue Type: Improvement
>            Reporter: Willem Jiang
>            Assignee: Willem Jiang
>             Fix For: 2.6.0
>
>
> When we export the JRE package from OSGi platform, there is no version range for the
package.
> Letting the camel bundle import the javax.* package with the version="[0.0, x) to help
it imports the package from JRE.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message