camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Willem Jiang (JIRA)" <>
Subject [jira] Commented: (CAMEL-3228) Upgrade to dozer 5.3.0
Date Thu, 25 Nov 2010 14:55:25 GMT


Willem Jiang commented on CAMEL-3228:


I just ran a test with the latest dozer-osgi 5.3.1,  and got the same error as claus got.
It looks like the classloader for the MappingValidator  is not set rightly.

Caused by: org.apache.camel.NoTypeConversionAvailableException: No type converter available
to convert from type: org.apache.camel.itest.osgi.dozer.service.Customer to the required type:
org.apache.camel.itest.osgi.dozer.model.Customer with value org.apache.camel.itest.osgi.dozer.service.Customer@5e149a
	at org.apache.camel.impl.converter.BaseTypeConverterRegistry.mandatoryConvertTo(
	at org.apache.camel.core.osgi.OsgiTypeConverter.mandatoryConvertTo(
	at org.apache.camel.impl.MessageSupport.getMandatoryBody(
	... 55 more
Caused by: org.dozer.MappingException: Unable to locate dozer mapping file [org/apache/camel/itest/osgi/dozer/dozer-mapping.xml]
in the classpath!
	at org.dozer.util.MappingUtils.throwMappingException(
	at org.dozer.util.MappingValidator.validateURL(
	at org.dozer.loader.CustomMappingsLoader.loadFromFiles(
	at org.dozer.loader.CustomMappingsLoader.load(
	at org.dozer.DozerBeanMapper.loadCustomMappings(
	at org.dozer.DozerBeanMapper.getMappingProcessor(
	at org.apache.camel.converter.dozer.DozerTypeConverter.convertTo(
	at org.apache.camel.converter.dozer.DozerTypeConverter.convertTo(
	at org.apache.camel.impl.converter.BaseTypeConverterRegistry.doConvertTo(
	at org.apache.camel.impl.converter.BaseTypeConverterRegistry.mandatoryConvertTo(
	... 57 more


> Upgrade to dozer 5.3.0
> ----------------------
>                 Key: CAMEL-3228
>                 URL:
>             Project: Apache Camel
>          Issue Type: Improvement
>            Reporter: Dmitry Buzdin
>            Assignee: Claus Ibsen
>             Fix For: 2.6.0
>         Attachments: CAMEL-3228_-_Upgrade_to_Dozer_5_3_0_.patch, dozer-osgi-5.3.0.jar,
>   Original Estimate: 6 hours
>  Remaining Estimate: 6 hours
> Dozer 5.3.0 has been released. It has changes in internal API, which make usage of dozer-camel
impossible with the most recent version.
> As Dozer maintainer I could contribute a patch upgrading camel-dozer module to use 5.3.0.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message