camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Buzdin (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CAMEL-3228) Upgrade to dozer 5.3.0
Date Thu, 25 Nov 2010 14:59:25 GMT

    [ https://issues.apache.org/activemq/browse/CAMEL-3228?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=63552#action_63552
] 

Dmitry Buzdin commented on CAMEL-3228:
--------------------------------------

@Willem the problem is that integration test creates Dozer instance via Spring directly, but
not with help of dozer-camel component.
If you do create a raw instance of dozer then it is not osgi compatible out of the box. Take
a look at tests in camel-dozer module to see the proper initialization code.

> Upgrade to dozer 5.3.0
> ----------------------
>
>                 Key: CAMEL-3228
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-3228
>             Project: Apache Camel
>          Issue Type: Improvement
>            Reporter: Dmitry Buzdin
>            Assignee: Claus Ibsen
>             Fix For: 2.6.0
>
>         Attachments: CAMEL-3228_-_Upgrade_to_Dozer_5_3_0_.patch, dozer-osgi-5.3.0.jar,
pom.xml
>
>   Original Estimate: 6 hours
>  Remaining Estimate: 6 hours
>
> Dozer 5.3.0 has been released. It has changes in internal API, which make usage of dozer-camel
impossible with the most recent version.
> As Dozer maintainer I could contribute a patch upgrading camel-dozer module to use 5.3.0.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message