camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: [DISCUSS] CXF 2.3 upgrade in Camel 2.6?
Date Thu, 04 Nov 2010 14:47:05 GMT
On Thursday 04 November 2010 10:40:18 am William Tam wrote:
> Willem and I would like to start a discussion regarding which release of
> Camel should be upgraded to CXF 2.3.  There is a lot of good reasons to
> upgrade to CXF 2.3.   However, upgrading it in Camel 2.6 could mean
> stopping supporting CXF 2.2.x in the future Camel 2.x releases.  (see
> https://issues.apache.org/activemq/browse/CAMEL-3308) It also means that
> users who upgrade to Camel 2.6 will be forced to upgrade to CXF 2.3.  It
> is almost certain that Camel 3 will have CXF 2.3.x, which (Camel 3) is
> targeted from 1st quarter of 2011.   It is not that far away.   So,
> let's hear your opinion on whether we should upgrade to CXF 2.3 in Camel
> 2.6 or not?

I think it needs to be.   Updating from 2.2 to 2.3 is a fairly minor upgrade 
(except for the continuation thing which was never documented and thus not 
likely used extensively at all).  With 2.2 likely to go into unsupported mode 
fairly soon, getting Camel out with 2.3 is pretty important.

I'd also like to get 2.3 into Camel quickly (at least for the builds) so we 
can identify anything that NEEDS to be fixed and get them into 2.3.1 which I'd 
like to do later this month.

The camel 3.0 version in Q1 is still not finalized/settled, so I wouldn't use 
that as part of the decision point.

Dan


> 
> Thanks,
> Willem and William

-- 
Daniel Kulp
dkulp@apache.org
http://dankulp.com/blog

Mime
View raw message