camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CAMEL-3228) Upgrade to dozer 5.3.0
Date Tue, 26 Oct 2010 08:55:41 GMT

    [ https://issues.apache.org/activemq/browse/CAMEL-3228?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=62830#action_62830
] 

Claus Ibsen commented on CAMEL-3228:
------------------------------------

Dmitry

Yeah the new JAR is much better than the old one. So I think you should go ahead and do a
5.3.1 release.

In terms of classloading. I would suggest to provide a SPI for end users so they can provide
URL or InputStream or something to load the resources.
This allows them to use Dozer in various servers which otherwise would have difficulty otherwise.
For example JBoss, WebSphere may have issues loading on classpath.
BEA WebLogic as well. etc.

In the camel-dozer component it allows us from Camel to use the SPI to ensure the resources
can be loaded using the Camel ClassResolver SPI
which we have adapters for OSGi, JBoss, WebSphere etc.

If you want to let OSGi be able to load from classpath and the end user can in fact put the
mapping files in any classpath they like.
So to remedy that you may have to enable the dynamic imports. 

In the pom.xml you can do:
<DynamicImport-Package>*</DynamicImport-Package>

This may give some other problems in the longer run.

> Upgrade to dozer 5.3.0
> ----------------------
>
>                 Key: CAMEL-3228
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-3228
>             Project: Apache Camel
>          Issue Type: Improvement
>            Reporter: Dmitry Buzdin
>            Assignee: Claus Ibsen
>             Fix For: 2.6.0
>
>         Attachments: CAMEL-3228_-_Upgrade_to_Dozer_5_3_0_.patch, dozer-osgi-5.3.0.jar,
pom.xml
>
>   Original Estimate: 6 hours
>  Remaining Estimate: 6 hours
>
> Dozer 5.3.0 has been released. It has changes in internal API, which make usage of dozer-camel
impossible with the most recent version.
> As Dozer maintainer I could contribute a patch upgrading camel-dozer module to use 5.3.0.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message