camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadrian Zbarcea (JIRA)" <j...@apache.org>
Subject [jira] Updated: (CAMEL-3091) QuartzEndpoint does not set the job name properly
Date Tue, 31 Aug 2010 01:59:41 GMT

     [ https://issues.apache.org/activemq/browse/CAMEL-3091?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Hadrian Zbarcea updated CAMEL-3091:
-----------------------------------

    Description: 
Looks like the job.name argument is not se properly on the endpoint and defaults to the uri
path.

Another nastier issue (for which I should have probably created a separate issue) is that
the uri gets messed up if it does not have the double slashes after the scheme (as in {{"quartz:<uri>"}}
vs {{"quartz://<uri>"}}) and the @cron argument contains '?'. The workaround (arguably)
is to start the uri with {{"quartz://..."}}.

  was:
Looks like the job.name argument is not se properly on the endpoint and defaults to the uri
path.

Another nastier issue (for which I should have probably created a separate issue) is that
the uri gets messed up if it does not have the double slashes after the scheme (as in {{"quartz:uri"}}
vs {{"quartz://"}}) and the @cron argument contains '?'. The workaround (arguably) is to start
the uri with {{"quartz://..."}}.


> QuartzEndpoint does not set the job name properly
> -------------------------------------------------
>
>                 Key: CAMEL-3091
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-3091
>             Project: Apache Camel
>          Issue Type: Bug
>          Components: camel-quartz
>    Affects Versions: 2.4.0
>            Reporter: Hadrian Zbarcea
>            Assignee: Hadrian Zbarcea
>             Fix For: 2.5.0
>
>
> Looks like the job.name argument is not se properly on the endpoint and defaults to the
uri path.
> Another nastier issue (for which I should have probably created a separate issue) is
that the uri gets messed up if it does not have the double slashes after the scheme (as in
{{"quartz:<uri>"}} vs {{"quartz://<uri>"}}) and the @cron argument contains '?'.
The workaround (arguably) is to start the uri with {{"quartz://..."}}.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message