camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charles Moulliard <cmoulli...@gmail.com>
Subject Strange error when deploying camel-2.4 on Karaf (1.99)
Date Mon, 12 Jul 2010 15:00:56 GMT
Hi,

When deploying Apache Camel 2.4 on Karaf 1.99.SNAPSHOT, I get the following
error:

karaf@root> features:removeUrl
mvn:org.apache.camel.karaf/apache-camel/2.4-SNAPSHOT/xml/features
karaf@root> features:install camel
RE: org.apache.felix.framework.resolver.ResolveException: Constraint
violation for package 'org.springframework.util' when resolving module 81.0
between existing import 6
6.0.org.springframework.util BLAMED ON [[81.0] package;
(&(package=org.springframework.util)(version>=2.5.6)(!(version>=4.0.0)))]
and uses constraint 46.0.org.springframe
work.util BLAMED ON [[81.0] package;
(&(package=org.springframework.osgi.io)(version>=1.2.0)(version<=1.2.0)),
[58.0] package; (&(package=org.springframework.core.io.supp
ort)(version>=2.5.6)(!(version>=4.0.0)))]
...

[  81] [Active     ] [            ] [       ] [   60] spring-osgi-core
(1.2.0)

I hope that this is not blocking for releasing of Camel 2.4

Kind regards,


Charles Moulliard

Senior Enterprise Architect (J2EE, .NET, SOA)
Apache Camel - ServiceMix Committer
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Blog : http://cmoulliard.blogspot.com |  Twitter :
http://twitter.com/cmoulliard
Linkedin : http://www.linkedin.com/in/charlesmoulliard | Skype: cmoulliard

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message