camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bengt Rodehav (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CAMEL-2959) Upgrade to JSch 0.1.43
Date Wed, 21 Jul 2010 20:12:52 GMT

    [ https://issues.apache.org/activemq/browse/CAMEL-2959?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=60833#action_60833
] 

Bengt Rodehav commented on CAMEL-2959:
--------------------------------------

I've been in touch with Atsuhiko Yamanaka (ymnk@jcraft.com). JSch is compatible with Java
1.5 (even with Java 1.4) 
and there are no plans to change that. He says we can build JSch ourselves (just download
the source from http://sourceforge.net/projects/jsch/files/jsch/jsch-0.1.43.zip/download).
Although this works fine, I'm trying to persuade him to also release a Java 1.4 compatible
as well.
His last reply was:

"Thank you for your suggestions.
We'll think of providing yet another jar file for JDK 1.4."

I guess we'll either have to wait a bit or bĂșild ourselves. I'm not sure if you usually rebuild
when you repackage for OSGI or
if you just change the manifest and use the original .class files. Maybye it's OK if we build
ourselves?

/Bengt

> Upgrade to JSch 0.1.43
> ----------------------
>
>                 Key: CAMEL-2959
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-2959
>             Project: Apache Camel
>          Issue Type: Improvement
>          Components: camel-ftp
>    Affects Versions: 2.4.0
>            Reporter: Bengt Rodehav
>            Assignee: Willem Jiang
>
> Important bugfixes regarding SFTP (in camel-ftp) have been made in JSch 0.1.43. Needs
to be incorporated into Camel.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message