camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem Jiang <willem.ji...@gmail.com>
Subject Re: AXIS 2-1.4.1 and Camel Integration
Date Fri, 04 Jun 2010 07:57:53 GMT
How did you send the request message to the "direct:start" ?
Maybe something wrong with that.

Willem


devkatiyar wrote:
> Hi 
> 
> Thanks for reply ..
> 
> I create end point using CXF bean using 3 party WSDL in generate classes  i
> have web service class interface 
> 
> Request SOAP :::
> <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
> <soap:Body>
> <ns1:prepareDataRequest xmlns:ns1="http://p3sservice.tsm.com">
> <ns3:providerID xmlns:ns2="http://p3sservice.tsm.com/xsd"
> xmlns:ns3="http://p3sservice.tsm.com">TSM</ns3:providerID>
> <ns3:CRN xmlns:ns2="http://p3sservice.tsm.com/xsd"
> xmlns:ns3="http://p3sservice.tsm.com">2345</ns3:CRN>
> <ns3:applicationID xmlns:ns2="http://p3sservice.tsm.com/xsd"
> xmlns:ns3="http://p3sservice.tsm.com">wallet01</ns3:applicationID>
> <ns3:strType xmlns:ns2="http://p3sservice.tsm.com/xsd"
> xmlns:ns3="http://p3sservice.tsm.com">download</ns3:strType>
> <ns3:scriptFragmentID xmlns:ns2="http://p3sservice.tsm.com/xsd"
> xmlns:ns3="http://p3sservice.tsm.com">personalize</ns3:scriptFragmentID>
> </ns1:prepareDataRequest>
> </soap:Body>
> </soap:Envelope>
> 
> 
> 
> Response SOAP :   
> 
> 
> <?xml version="1.0" encoding="http://schemas.xmlsoap.org/soap/envelope/"
> standalone="no"?>
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
> <soapenv:Body>
> <ns:prepareDataRequestResponse xmlns:ns="http://p3sservice.tsm.com">
> <ns:return xmlns:ax23="http://p3sservice.tsm.com/xsd"
> type="tsm.p3sservice.Result">
> <ax23:errorCode>0</ax23:errorCode>
> <ax23:errorContext xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:nil="true"/>
> <ax23:succeeded>true</ax23:succeeded>
> </ns:return>
> </ns:prepareDataRequestResponse>
> </soapenv:Body>
> </soapenv:Envelope>
> 
> 
> when testing junit webservice end using <direct:start> <to
> uri="cxf:bean:p3serviceEndpoint" />  
> 
> Thanks for reply ..
> 
>  
> 
> then response object is Null ...
> 
> 
> 
> 
> 
> 
> Claus Ibsen-2 wrote:
>> Hi
>>
>> You are a bit cheap on the details.
>>
>> Camel does not have any specific axis2 component.
>> So just invoke the Axis2 webservice and get the reply using regular
>> code in the way Axis2 does that.
>>
>> And you can do that from a Camel route by letting Camel invoke a bean
>> where you in the bean invoke the webservice.
>> http://camel.apache.org/bean
>>
>> If you on the other hand want to use a axis webservice as input to a
>> Camel route. Then take a look at his example.
>> Its using Axis 1.4 but the principle applies for Axis 2 as well
>> http://camel.apache.org/tutorial-axis-camel.html
>>
>>
>>
>> On Fri, Jun 4, 2010 at 7:24 AM, devkatiyar <devendrakatiyar@gmail.com>
>> wrote:
>>> Hi ,
>>> I am calling axis2 web service end point from camel ..
>>>
>>>
>>> request SOAP is ok but response SOAP is  also coming fine ... when when
>>> using Junit test case i am printing the result ...
>>>
>>>
>>> result is :  null
>>>
>>> can any help me ..
>>>
>>>
>>> or any one have working example  with axis2 integration  with camel or
>>> any
>>> other resources
>>>
>>>
>>> Thanks ...
>>>
>>>
>>> Devendra
>>> --
>>> View this message in context:
>>> http://old.nabble.com/AXIS-2-1.4.1--and-Camel-Integration-tp28775863p28775863.html
>>> Sent from the Camel Development mailing list archive at Nabble.com.
>>>
>>>
>>
>>
>> -- 
>> Claus Ibsen
>> Apache Camel Committer
>>
>> Author of Camel in Action: http://www.manning.com/ibsen/
>> Open Source Integration: http://fusesource.com
>> Blog: http://davsclaus.blogspot.com/
>> Twitter: http://twitter.com/davsclaus
>>
>>
> 


Mime
View raw message