camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem Jiang <willem.ji...@gmail.com>
Subject Re: Camel and Spring in 2.3
Date Fri, 21 May 2010 07:50:44 GMT
Hi,

Which version of Spring 3.x are you using?
I just checked the camel code with Spring 3.0.2 in the eclipse, there is 
no any complain about it.

As the TaskExecutor is extends the JDK's TaskExecutor.

Willem

Dmitry Buzdin wrote:
> In latest release Spring dropped support of Java 1.4 and migrated custom
> TaskExecutor API to JDK TaskExecutor.
> 
> Dmitry
> 
> 
> Dmitry Buzdin wrote:
>> Hello,
>>
>> We are considering usage of Camel together with Spring 3.0. There is one
>> API incompatibility, which blocks us from going forward.
>>
>> Question is whether Camel is meant to be compatible to 3.0 or still on 2.5
>> branch. The problem is that TaskExecutor related API changed in Spring 3
>> significantly, which results in NoSuchMethodError.
>>
>> java.lang.NoSuchMethodError:
>> org.springframework.jms.listener.DefaultMessageListenerContainer.setTaskExecutor(Lorg/springframework/core/task/TaskExecutor;)V
>>  at
>> org.apache.camel.component.jms.JmsConfiguration.configureMessageListenerContainer(JmsConfiguration.java:1072)
>>  at
>> org.apache.camel.component.jms.JmsConfiguration.createMessageListenerContainer(JmsConfiguration.java:512)
>>  at
>> org.apache.camel.component.jms.JmsEndpoint.createConsumer(JmsEndpoint.java:135)
>>  at
>> org.apache.camel.component.jms.JmsEndpoint.createConsumer(JmsEndpoint.java:55)
>>
>> Regards,
>> Dmitry Buzdin
>>
> 


Mime
View raw message