camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pete Mueller (JIRA)" <>
Subject [jira] Updated: (CAMEL-2659) apache-camel features file has unused reference to karaf-1.2.0
Date Tue, 20 Apr 2010 09:56:13 GMT


Pete Mueller updated CAMEL-2659:

    Attachment: apache-camel.xml

I have enclosed a modified version of the feature file with the recommended changes.  I have
tested this file with karaf-1.2 and karaf-1.4 with no issues so far.

> apache-camel features file has unused reference to karaf-1.2.0
> --------------------------------------------------------------
>                 Key: CAMEL-2659
>                 URL:
>             Project: Apache Camel
>          Issue Type: Bug
>          Components: karaf
>    Affects Versions: 2.2.0
>            Reporter: Pete Mueller
>         Attachments: apache-camel.xml
> The apache-camel.xml features file for felix/karaf has a repository element referencing
karaf 1.2.0  This creates an odd installation when using karaf 1.4, as the karaf 1.2 repo
is loaded along with the 1.4 repo, even tho they have the same feature list.  It seem this
inclusion is for the spring and spring-dm features, which are the same in karaf-1.2 and karaf-1.4.
> Recommend removing this repository element and/or (if possible) indicating that the version
of the spring/spring-dm feature is 1.2.0+.  I know this is possible for bundles, but not sure
if the capability exists for features.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message