camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CAMEL-1530) Upgrade camel-http to use httpclient 4.0
Date Tue, 23 Feb 2010 09:28:40 GMT

    [ https://issues.apache.org/activemq/browse/CAMEL-1530?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=57799#action_57799
] 

Claus Ibsen commented on CAMEL-1530:
------------------------------------

[10:29]  <cibsen> gnodet I tried to install the httpclient-osgi bundle in FUSE ESB 4.2
[10:29]  <cibsen> [ 179] [Installed  ] [            ] [       ] [   60] Apache HttpClient
OSGi bundle (4.0.1)
[10:29]  <cibsen> karaf@root> osgi:start 179
[10:29]  <cibsen> The bundle could not be resolved. Reason: Missing Constraint: Import-Package:
org.apache.http; version="0.0.0"
[10:29]  <cibsen> using
[10:29]  <cibsen> osgi:install mvn:org.apache.httpcomponents/httpclient-osgi/4.0.1
[10:30]  <cibsen> I recon they have some issue in their MANIFEST.MF file?


> Upgrade camel-http to use httpclient 4.0
> ----------------------------------------
>
>                 Key: CAMEL-1530
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-1530
>             Project: Apache Camel
>          Issue Type: Improvement
>          Components: camel-http
>    Affects Versions: 2.0-M1
>            Reporter: Claus Ibsen
>            Assignee: Christian Mueller
>             Fix For: 2.3.0
>
>         Attachments: camel-gae_20100211.patch, camel-http.zip, camel-http_20100211.patch,
camel-jetty.zip, camel-jetty_20100211.patch, camel-servlet_20100211.patch, localhost.ks
>
>          Time Spent: 4 weeks
>  Remaining Estimate: 0 minutes
>
> Upgrading httpclient from 3.1 to 4.0 requires changes in the camel-http code as the API
has change quite a lot.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message