camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michiel Eggermont (JIRA)" <j...@apache.org>
Subject [jira] Created: (CAMEL-2491) Cannot deploy camel-core in OSGI-runtime using Spring 3.0
Date Mon, 22 Feb 2010 10:48:40 GMT
Cannot deploy camel-core in OSGI-runtime using Spring 3.0
---------------------------------------------------------

                 Key: CAMEL-2491
                 URL: https://issues.apache.org/activemq/browse/CAMEL-2491
             Project: Apache Camel
          Issue Type: Bug
          Components: camel-core
    Affects Versions: 2.2.0
         Environment: DM Server 2.0
            Reporter: Michiel Eggermont


It is not possible to start a bundle with a camelContext in dm-server 2.0 while using camel-core
version 2.2.0, because camel-core requires Spring packages of version below 3.0. This seems
like an issue to me, since the release notes of version 2.2.0 suggest that it works with version
3.0 of Spring. 
 
Environment: Spring dm-server 2.0 (comes pre-packaged with Spring 3.0.0.RELEASE)
Steps to reproduce the problem:
- start dm-server
- install bundle camel-core-2.2.0.jar
- install a bundle containing any kind of camelContext
Error: 
Caused by: com.springsource.kernel.osgi.framework.ExtendedClassNotFoundException: org.springframework.jmx.export.metadata.JmxAttributeSource
in KernelBundleClassLoader: [bundle=org.apache.camel.camel-core_2.2.0]
(I can send the full stack trace if required)

Cause: 
The version range for the JMX spring packages in the MANIFEST.MF:
org.springframework.jmx.export.annotation;resolution:=optional;version="[2.5,3)"
,org.springframework.jmx.export.assembler;resolution:=optional;version="[2.5,3)"
,org.springframework.jmx.export.metadata;resolution:=optional;version="[2.5,3)" 

As a workaround I disabled the jmxAgent in my camel-context and changed the 
version range to [2.5,4) in the MANIFEST.MF file in my camel-core-2.2.0.jar.
I redeployed the camel-core bundle. After that my bundle started without any problems. 

Proposed solution:
Change the version range for Spring packages in camel-core from [2.5,3) to [2.5,4)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message