camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] Created: (CAMEL-2342) camel-example-spring-javaconfig - Uses Spring 2.5.x instead of Spring 3.0 and cannot compile
Date Thu, 07 Jan 2010 12:46:16 GMT
camel-example-spring-javaconfig - Uses Spring 2.5.x instead of Spring 3.0 and cannot compile
--------------------------------------------------------------------------------------------

                 Key: CAMEL-2342
                 URL: https://issues.apache.org/activemq/browse/CAMEL-2342
             Project: Apache Camel
          Issue Type: Task
          Components: examples
    Affects Versions: 2.2.0
            Reporter: Claus Ibsen
            Assignee: Willem Jiang
            Priority: Minor
             Fix For: 2.2.0


{code}
[INFO] Compilation failure

/Users/davsclaus/workspace/camel/examples/camel-example-spring-javaconfig/src/main/java/org/apache/camel/example/spring/javaconfig/MyRouteConfig.java:[21,27]
package org.apache.activemq does not exist

/Users/davsclaus/workspace/camel/examples/camel-example-spring-javaconfig/src/main/java/org/apache/camel/example/spring/javaconfig/MyRouteConfig.java:[33,46]
cannot find symbol
symbol  : class Bean
location: package org.springframework.context.annotation

/Users/davsclaus/workspace/camel/examples/camel-example-spring-javaconfig/src/main/java/org/apache/camel/example/spring/javaconfig/MyRouteConfig.java:[34,46]
cannot find symbol
symbol  : class Configuration
location: package org.springframework.context.annotation

/Users/davsclaus/workspace/camel/examples/camel-example-spring-javaconfig/src/main/java/org/apache/camel/example/spring/javaconfig/MyRouteConfig.java:[43,1]
cannot find symbol
symbol: class Configuration
@Configuration

/Users/davsclaus/workspace/camel/examples/camel-example-spring-javaconfig/src/main/java/org/apache/camel/example/spring/javaconfig/MyRouteConfig.java:[95,5]
cannot find symbol
symbol  : class Bean
location: class org.apache.camel.example.spring.javaconfig.MyRouteConfig

/Users/davsclaus/workspace/camel/examples/camel-example-spring-javaconfig/src/main/java/org/apache/camel/example/spring/javaconfig/MyRouteConfig.java:[82,8]
cannot find symbol
symbol  : class ActiveMQConnectionFactory
location: class org.apache.camel.example.spring.javaconfig.MyRouteConfig

/Users/davsclaus/workspace/camel/examples/camel-example-spring-javaconfig/src/main/java/org/apache/camel/example/spring/javaconfig/MyRouteConfig.java:[82,58]
cannot find symbol
symbol  : class ActiveMQConnectionFactory
location: class org.apache.camel.example.spring.javaconfig.MyRouteConfig
{code}

It pulls down spring version 2.5.x instead of 3.0 which then cannot compile the example.
{code}
davsclaus:(svn)camel[trunk:896832]/examples/camel-example-spring-javaconfig$ mvn dependency:tree
[INFO] Scanning for projects...
[INFO] Searching repository for plugin with prefix: 'dependency'.
[INFO] ------------------------------------------------------------------------
[INFO] Building Camel :: Example :: Spring :: JavaConfig
[INFO]    task-segment: [dependency:tree]
[INFO] ------------------------------------------------------------------------
[INFO] [dependency:tree]
[INFO] org.apache.camel:camel-example-spring-javaconfig:bundle:2.2-SNAPSHOT
[INFO] +- org.apache.camel:camel-spring:jar:2.2-SNAPSHOT:compile
[INFO] |  \- org.apache.camel:camel-core:jar:2.2-SNAPSHOT:compile
[INFO] |     +- commons-logging:commons-logging-api:jar:1.1:compile
[INFO] |     \- org.fusesource.commonman:commons-management:jar:1.0:compile
[INFO] +- org.apache.camel:camel-spring-javaconfig:jar:2.2-SNAPSHOT:compile
[INFO] |  +- org.springframework:spring-aop:jar:2.5.6:compile (version managed from 3.0.0.RELEASE)
[INFO] |  |  +- aopalliance:aopalliance:jar:1.0:compile
[INFO] |  |  \- commons-logging:commons-logging:jar:1.1.1:compile
[INFO] |  +- org.springframework:spring-beans:jar:2.5.6:compile
[INFO] |  +- org.springframework:spring-context:jar:2.5.6:compile (version managed from 3.0.0.RELEASE)
[INFO] |  +- org.springframework:spring-core:jar:2.5.6:compile
[INFO] |  +- net.sourceforge.cglib:com.springsource.net.sf.cglib:jar:2.1.3:compile
[INFO] |  \- org.springframework:spring-test:jar:2.5.6:compile (version managed from 3.0.0.RELEASE)
[INFO] +- org.apache.camel:camel-osgi:jar:2.2-SNAPSHOT:compile
[INFO] |  +- org.springframework.osgi:spring-osgi-core:jar:1.2.0:compile
[INFO] |  |  \- org.springframework.osgi:spring-osgi-io:jar:1.2.0:compile
[INFO] |  +- javax.xml.bind:jaxb-api:jar:2.1:compile
[INFO] |  |  +- javax.xml.stream:stax-api:jar:1.0-2:compile
[INFO] |  |  \- javax.activation:activation:jar:1.1:compile
[INFO] |  \- com.sun.xml.bind:jaxb-impl:jar:2.1.12:compile
[INFO] +- org.apache.camel:camel-jms:jar:2.2-SNAPSHOT:compile
[INFO] |  \- org.apache.geronimo.specs:geronimo-jms_1.1_spec:jar:1.1.1:compile
[INFO] +- org.apache.activemq:activemq-core:jar:5.3.0:test
[INFO] |  +- org.apache.activemq:activeio-core:jar:3.1.2:test
[INFO] |  |  \- org.apache.geronimo.specs:geronimo-j2ee-management_1.1_spec:jar:1.0.1:test
[INFO] |  +- org.apache.activemq:kahadb:jar:5.3.0:test
[INFO] |  +- org.apache.activemq.protobuf:activemq-protobuf:jar:1.0:test
[INFO] |  +- org.apache.geronimo.specs:geronimo-j2ee-management_1.0_spec:jar:1.1:test (version
managed from 1.0)
[INFO] |  \- commons-net:commons-net:jar:2.0:test
[INFO] +- org.apache.felix:org.osgi.core:jar:1.2.0:compile
[INFO] +- log4j:log4j:jar:1.2.14:compile
[INFO] \- junit:junit:jar:4.4:test (scope not updated to compile)
[INFO] ------------------------------------------------------------------------
{code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message