camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <>
Subject [jira] Resolved: (CAMEL-1298) Resolve the mvn -Psetup.eclipse profile
Date Thu, 03 Dec 2009 11:39:53 GMT


Claus Ibsen resolved CAMEL-1298.

    Resolution: Duplicate

Willem have fixed it just recently

> Resolve the mvn -Psetup.eclipse profile
> ---------------------------------------
>                 Key: CAMEL-1298
>                 URL:
>             Project: Apache Camel
>          Issue Type: Task
>          Components: tooling
>    Affects Versions: Future
>         Environment: Eclipse
> Maven
>            Reporter: Ramon Buckland
>            Priority: Minor
>             Fix For: Future
> mvn -Psetup.eclipse is not working as expected.
> The idea is that it builds a nice workspace with correct formatting rules as per project
standard and performs a logical eclipse:eclipse on all projects.
> it behaves differently to eclipse:eclipse however, dieing when it encounters (something
about) new projects (such as a new component, perhaps not built yet ? is jat not in the repo
? )
> {quote}
>  I have been playing with 'mvn -Psetup.eclipse -Declipse.workspace.dir=/path/to/your/workspace'
and came across some more issues. 
>  It seems that it configures the workspace okay, and then moves onto eclipse:eclipse
for each project. (or building something in each project).
>  That 'something fails', on various projects with classes not defined. 
>  I suspect it might be because the actual jar is not in my local repo (not confirmed
though) .. I gather this, perhaps, because the projects that it fails to compile are ones
which are new (freemarker, my new commons-vfs) 
>  hrmm .. not sure what it is.
>  My eclipse workspace now has activemq code standards.
>  (a note on that mvn -Psetup.eclipse) So I had a have a new component (commons-vfs).
When I ran -Psetup.eclipse the first time. It failed stating that all my super classes were
not available. (they are in camel-core) .. I mvn clean'd and reran. it still failed, so I
commented it out of components/pom.xml
>  3rd run - components/camel-freemarker failed with the same sort of error. Symbol not
found (for superclasses it uses).
> {quote}

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message