camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <>
Subject [jira] Commented: (CAMEL-1530) Upgrade camel-http to use httpclient 4.0
Date Mon, 21 Dec 2009 05:52:52 GMT


Claus Ibsen commented on CAMEL-1530:

Yeah for now lets delete the {{HttpInvalidHttpClientConfigurationTest}} test.

I can see its a {{Map}} structure now for configuring the client. Wonder how they validate
the parameters, or do they just ignore unknown parameters?
How do you set the timeout on the client?

Later we can add support for grabbing parameters into a map.

Then we can grab those 2 parameters

And put the on the HttpParams map using
params.setParameter("foo", "123");
params.setParameter("bar", "cheese");

Then its easy for end users if they need a few http client parameters as they can specify
that in the URL (as they could with http client 3.1)

> Upgrade camel-http to use httpclient 4.0
> ----------------------------------------
>                 Key: CAMEL-1530
>                 URL:
>             Project: Apache Camel
>          Issue Type: Improvement
>          Components: camel-http
>    Affects Versions: 2.0-M1
>            Reporter: Claus Ibsen
>            Assignee: Christian Mueller
>             Fix For: 2.2.0
> Upgrading httpclient from 3.1 to 4.0 requires changes in the camel-http code as the API
has change quite a lot.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message