camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <>
Subject [jira] Commented: (CAMEL-1530) Upgrade camel-http to use httpclient 4.0
Date Mon, 21 Dec 2009 18:23:54 GMT


Claus Ibsen commented on CAMEL-1530:

Jesus this tops the most unfriendly configuration I have seen in long time. Wonder ever if
they think that is easy to wire up with Spring XML ? 

And what does the {{ConPerRouteBean}} bring in that simply just {{5}} does not bring? At least
a simple configuration with most common options where plain simple values can be used to set
timeout, max connections and what not.

We can always make it a bit friendlier in the URI as we can offer easy to set options and
mess with the ugly API underneath.

Christian does this apply for all the other kind of options to set on the HttpClient?

> Upgrade camel-http to use httpclient 4.0
> ----------------------------------------
>                 Key: CAMEL-1530
>                 URL:
>             Project: Apache Camel
>          Issue Type: Improvement
>          Components: camel-http
>    Affects Versions: 2.0-M1
>            Reporter: Claus Ibsen
>            Assignee: Christian Mueller
>             Fix For: 2.2.0
> Upgrading httpclient from 3.1 to 4.0 requires changes in the camel-http code as the API
has change quite a lot.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message