camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shailesh Soliwal (JIRA)" <j...@apache.org>
Subject [jira] Updated: (CAMEL-1994) WS-Adressing: No headers in the respose, [MAPs retrieved from message null]
Date Mon, 07 Sep 2009 16:46:12 GMT

     [ https://issues.apache.org/activemq/browse/CAMEL-1994?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Shailesh Soliwal updated CAMEL-1994:
------------------------------------

    Attachment: ebxml_request.xml
                logs.txt
                IHEXDS.zip

Error logfile, sample xml request and eclipse project

> WS-Adressing: No headers in the respose, [MAPs retrieved from message null]
> ---------------------------------------------------------------------------
>
>                 Key: CAMEL-1994
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-1994
>             Project: Apache Camel
>          Issue Type: Bug
>          Components: camel-cxf
>    Affects Versions: 2.0.0
>         Environment: Windows XP, Camel 2.0.0, JDK 1.5, Soap-UI
>            Reporter: Shailesh Soliwal
>         Attachments: ebxml_request.xml, IHEXDS.zip, logs.txt
>
>
> I am using a cxf endpoint configured in POJO mode and running in wsdl-first-approach.
When a web-service client(Soap-UI) send a request with headers, it expects headers back with
appropriate response Action defined in wsdl, however, with this configuration no headers are
not being sent back.
> Please find attached logs, a sample project, and a sample xml request.
> Some more details:
> Endpoint configuration: CxfEndpoint, WSAdressing Feature enabled, Wsdl First approach
> Camel Version: 2.0.0
> CXF Version: 2.2.2

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message