camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem Jiang <willem.ji...@gmail.com>
Subject Question about load the camel-core feature with PAX-Exam
Date Fri, 24 Apr 2009 14:47:26 GMT
Hi Gert,

I'm try to load the Camel 2.0 SNAPSHOT features from the PAX-Exam.
I got below error when the PAX-Runner load the below bundle
<bundle>mvn:org.apache.servicemix.specs/org.apache.servicemix.specs.jaxb-api-2.1/1.3.0</bundle>

BTW, If I remove the jaxb-api bundle, the camel-context can be start
without any error.
Did I miss some thing ?

## DEBUG: errors - FrameworkErrorEvent bundle #7
## DEBUG: errors - FrameworkErrorEvent throwable:
org.osgi.framework.BundleException: Unable to resolve bundle: missing
package(s) or can not resolve all of the them:
javax.xml.stream;version=1.0.0
	at
org.knopflerfish.framework.BundleImpl.getUpdatedState(BundleImpl.java:1036)
	at org.knopflerfish.framework.BundleImpl.start(BundleImpl.java:312)
	at
org.knopflerfish.framework.StartLevelImpl.increaseStartLevel(StartLevelImpl.java:278)
	at org.knopflerfish.framework.StartLevelImpl$1.run(StartLevelImpl.java:210)
	at org.knopflerfish.framework.StartLevelImpl.run(StartLevelImpl.java:171)
	at java.lang.Thread.run(Thread.java:595)
org.osgi.framework.BundleException: Failed, missing package(s) or can
not resolve all of the them: javax.xml.stream;version=1.0.0
	at org.knopflerfish.framework.BundleImpl.start(BundleImpl.java:314)
	at
org.knopflerfish.framework.StartLevelImpl.increaseStartLevel(StartLevelImpl.java:278)
	at org.knopflerfish.framework.StartLevelImpl$1.run(StartLevelImpl.java:210)
	at org.knopflerfish.framework.StartLevelImpl.run(StartLevelImpl.java:171)
	at java.lang.Thread.run(Thread.java:595)

Willem

Mime
View raw message