camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Willem Jiang (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (CAMEL-1481) OsgiResolverUtil(OsgiPackageScanClassResolver) should use the regular classloader if the osgi bundle classloader can't find any class
Date Fri, 27 Mar 2009 03:54:42 GMT

     [ https://issues.apache.org/activemq/browse/CAMEL-1481?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Willem Jiang resolved CAMEL-1481.
---------------------------------

    Resolution: Fixed

trunk
http://svn.apache.org/viewvc?rev=757790&view=rev
camel 1.x branch
http://svn.apache.org/viewvc?rev=757863&view=rev

> OsgiResolverUtil(OsgiPackageScanClassResolver) should use the regular classloader if
the osgi bundle classloader can't find any class 
> --------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: CAMEL-1481
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-1481
>             Project: Apache Camel
>          Issue Type: Improvement
>          Components: camel-osgi
>    Affects Versions: 1.6.0, 2.0-M1
>            Reporter: Willem Jiang
>            Assignee: Willem Jiang
>             Fix For: 2.0.0, 1.6.1
>
>
> Since ServiceMix4 also supports the old JBI service unit and the classloader is not osgi
bundle class loader, 
> the OsgiResolverUtil should use the regular classloader if the osgi bundle classloader
can't find any class.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message