camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From orton <o_hu...@yahoo.com>
Subject Re: Camel 1.6/2.0 MINA UDP issue
Date Tue, 10 Mar 2009 13:19:39 GMT

> What version of Camel and Mina are you using?

I tried it out on the Camel 1.6 bin release and I compiled the Camel 2.0
snapshot in svn and both appeared to have the same problem... mina-core for
both appear to be 1.1.7

> Mina is in the works of doing a Mina 2.0 that might be much better.
> When its release we will upgrade it in Camel 2.0 as well.

> Yes the memory leaks is interresting? Where did you find them?

I only saw some references in past forums and some of my co-workers have
mentioned them to me also, will look for more details and send to you

> And whats the relevanse of you test? Sending 65.000 udp packages to
> yourself?
> Are you using Camel to be the Mina server as well? Or do you send it
> to another JVM?

We're trying to do some simple stress and overhead testing on the Camel
components... We really like what you guys have done with it and find the
patterns extremely useful. We want to see how suitable it is for
applications with high throughput, low latency needs and what the extra cost
for using Camel is. I have separate servers in different VM's but on the
same host for now. 


> Using TCP that works. Are you using the exact same sample but just
> change udp to tcp in the endpoint URI?

I send the exact same samples with UDP and TCP... Just tried the multicast
one and it gives me the same issue as the UDP one...


-- 
View this message in context: http://www.nabble.com/Camel-1.6-2.0-MINA-UDP-issue-tp22426433p22434032.html
Sent from the Camel - Development (activemq) mailing list archive at Nabble.com.


Mime
View raw message