camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <>
Subject [jira] Commented: (CAMEL-1395) Refactor - All models classes xxxType renamed to xxxDefinition
Date Fri, 06 Mar 2009 08:51:44 GMT


Claus Ibsen commented on CAMEL-1395:

And we should consider the xxxRef to be xxxRefDefinition also. As they are all defintions
of the model.

And in fact I am wondering if xxxRef is a bad name, it should be without the Ref. But we should
get a talk with James about this.

> Refactor - All models classes xxxType renamed to xxxDefinition
> --------------------------------------------------------------
>                 Key: CAMEL-1395
>                 URL:
>             Project: Apache Camel
>          Issue Type: Task
>          Components: camel-core
>            Reporter: Claus Ibsen
>            Assignee: Hadrian Zbarcea
>             Fix For: 2.0-M1
> From James
> As an aside I wonder if one of these days we should refactor
> org.apache.camel.model.*Type to be *Definition as thats kinda what
> they are - the logical, design type definition of routes. For example
> the SplitterDefintion just defines how to create a  Splitter, its not
> a Splitter (the Processor in the processor package).

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message