camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Strachan <>
Subject minor refactoring - FooHelper -> Foos
Date Wed, 18 Feb 2009 12:49:35 GMT
One naming convention I really like from the Google Collections
library is using the plural name of a type/interface/base class as the
helper class for static helper methods.

So we could rename things like ExchangeHelper to Exchanges,
CamelContextHelper to CamelContexts. Much neater IMHO.

These helper classes are all internal mostly for Camel implementation
details; so wondering if it'd make sense to refactor them for 2.0?


Open Source Integration

View raw message