camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: minor refactoring - FooHelper -> Foos
Date Wed, 18 Feb 2009 13:02:55 GMT
However we have to be a bit careful when svnmerge from trunk to 1.x if
we use a helper etc. as they have different name on trunk

On Wed, Feb 18, 2009 at 1:59 PM, Claus Ibsen <claus.ibsen@gmail.com> wrote:
> On Wed, Feb 18, 2009 at 1:49 PM, James Strachan
> <james.strachan@gmail.com> wrote:
>> One naming convention I really like from the Google Collections
>> library is using the plural name of a type/interface/base class as the
>> helper class for static helper methods.
>>
>> So we could rename things like ExchangeHelper to Exchanges,
>> CamelContextHelper to CamelContexts. Much neater IMHO.
>>
>> These helper classes are all internal mostly for Camel implementation
>> details; so wondering if it'd make sense to refactor them for 2.0?
>> Thoughts?
> +1
>
> Like java.util.Collections or java.util.Arrays :)
>
> What about those util classes?
> ResolverUtil (I dislike this name, as its not a light weight util class)
>
> And if we had a StringUtil that many framework have, should it be Strings
> And ObjectHelper should be Objects?
>
> A bit close to Object/String maybe hard to spot.
>
>
>>
>> --
>> James
>> -------
>> http://macstrac.blogspot.com/
>>
>> Open Source Integration
>> http://fusesource.com/
>>
>
>
>
> --
> Claus Ibsen
> Apache Camel Committer
>
> Open Source Integration: http://fusesource.com
> Blog: http://davsclaus.blogspot.com/
>



-- 
Claus Ibsen
Apache Camel Committer

Open Source Integration: http://fusesource.com
Blog: http://davsclaus.blogspot.com/

Mime
View raw message