camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] Created: (CAMEL-1380) Aggregator - completedPredicate should be renamed to completionPredicate to be in line with wording
Date Wed, 25 Feb 2009 07:45:59 GMT
Aggregator - completedPredicate should be renamed to completionPredicate to be in line with
wording
---------------------------------------------------------------------------------------------------

                 Key: CAMEL-1380
                 URL: https://issues.apache.org/activemq/browse/CAMEL-1380
             Project: Apache Camel
          Issue Type: Task
          Components: camel-core
            Reporter: Claus Ibsen
            Assignee: Claus Ibsen
            Priority: Trivial
             Fix For: 2.0.0


{code:xml}
            <aggregate strategyRef="bestQuote">
                <correlationExpression>
                    <header id="loandId"/>
                </correlationExpression>
                <completedPredicate>
                    <simple>${header.CamelAggregatedCount} > 2</simple>
                </completedPredicate>
            </aggregate>
{code}

Should be:
{code}
            <aggregate strategyRef="bestQuote">
                <correlationExpression>
                    <header id="loandId"/>
                </correlationExpression>
                <completionPredicate>
                    <simple>${header.CamelAggregatedCount} > 2</simple>
                </completionPredicate>
            </aggregate>
{code}

So its in line with the correlation expression

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message