camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruce Snyder" <bruce.sny...@gmail.com>
Subject Fwd: FW: [nexus-user] Bad metadata in central repo - nexus to the rescue ?
Date Tue, 23 Dec 2008 22:58:51 GMT
It looks like the Maven metadata for Camel is incorrect. Can someone
correct this?

Bruce

------ Forwarded Message
From: Thomas Dudziak <tomdzk@gmail.com>
Reply-To: <nexus-user@sonatype.org>
Date: Tue, 23 Dec 2008 11:39:40 -0800
To: <nexus-user@sonatype.org>
Subject: [nexus-user] Bad metadata in central repo - nexus to the rescue ?

Hi all,

I yesterday tried to build a project that depends on
org.apache.camel:camel-core, version 1.4. Our trusty Nexus repository
dutifully tried to fetch the artifact from the central repos (we have
both Maven2 and Ibiblio configured), but failed with

[INFO] Failed to resolve artifact.

Couldn't find a version in [1.5.0] to match range [1.4.0,1.4.0]
 org.apache.camel:camel-core:jar:null

from the specified remote repositories:
 snapshots (http://public-snapshots),
 central (http://central)

So I did some spot checking in the repo, and the 1.4 version seems to
be in the repo:

http://repo2.maven.org/maven2/org/apache/camel/camel-core/1.4.0/

(along with other, older versions).
However, the metadata file only lists the latest version:

<metadata>
<groupId>org.apache.camel</groupId>
<artifactId>camel-core</artifactId>
<version>1.5.0</version>
<versioning>
<release>1.5.0</release>
<versions>
<version>1.5.0</version>
</versions>
<lastUpdated>20081028033115</lastUpdated>
</versioning>
</metadata>

Of course this is a really stupid bug in the central repo software,
but what I'm actually wondering is, whether Nexus could help in cases
like this ? Since the artifact is obviously there (as a simple HTTP
GET or perhaps even HEAD can prove), would it be possible for Nexus to
bypass the metadata file and fetch the artifact directly from its
designated location ? As far as I'm aware, there are lots of these bad
metadata files in the central repo, and having to upload them manually
is really painful.


-- 
perl -e 'print unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
);'

Apache ActiveMQ - http://activemq.org/
Apache Camel - http://activemq.org/camel/
Apache ServiceMix - http://servicemix.org/

Blog: http://bruceblog.org/

Mime
View raw message