camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen" <claus.ib...@gmail.com>
Subject Re: [jira] Created: (CAMEL-1183) rename multicast -> wireTap in the Java DSL and XML config?
Date Thu, 11 Dec 2008 15:45:43 GMT
On Thu, Dec 11, 2008 at 2:58 PM, James Strachan
<james.strachan@gmail.com> wrote:
> 2008/12/11 Ramon Buckland <ramon@thebuckland.com>:
>> Refresh my memory - what is it about wireTap that doesn't suit? (If
>>> you maybe swizzle your understanding of wire tap to be - send a copy
>>> of the same message to N destinations rather than just 2 :)
>>>
>>>
>> To me wireTap feels / sounds like a way to "tap into" a message, where the
>> *other* receivers are not the primary, ie, that there is one primary and
>> 'tapped to' endpoints are secondary.
>>
>> Think of MI5, FBI or AFP (aussie fed police) tapping your phone, they are
>> not the intended recipient of the message, but they get one (lots).
>>
>> In a loan broker example, where we call out to multiple loan providers, they
>> are all the intended recipient, so the wireTap seems though it is not suited
>> for this position, based on it's name.
>>
>>    "I don't want to "wire tap" a message to them, I want to send to all."
>>
>> My current use of the <multicast> and in documentation I explain to others
>> kind of fits into a Blind (don't look at message) Recipient List.
>>
>> .. hope that makes sense. (and the icon fits)
>> http://www.eaipatterns.com/RecipientList.html
>
>
> Yeah. Maybe we just add wireTap in and under the covers the
> implementation is kinda similar but we preserve multicast as a name?
+1 on keeping multicast (or if we really can find a better name)
+1 on adding wiretap to the DSL that uses multicast under the covers


>
>
>
> --
> James
> -------
> http://macstrac.blogspot.com/
>
> Open Source Integration
> http://fusesource.com/
>



-- 

/Claus Ibsen
Apache Camel Committer
Blog: http://davsclaus.blogspot.com/

Mime
View raw message