camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <>
Subject [jira] Commented: (CAMEL-64) Camel DSL should use verbs for it's EIP actions.
Date Fri, 14 Nov 2008 07:21:05 GMT


Claus Ibsen commented on CAMEL-64:

Well first of all the javadoc was wrong - I created a ticket CAMEL-1087

I thought the idea of this ticket was to use better wording (verbs) for the DSL

So for instance if you have a route like:

Then when you read it in English it's not correct. It should be:

The same applies for
splitter -> split
aggregator -> aggregate
delayer -> delay

> Camel DSL should use verbs for it's EIP actions. 
> -------------------------------------------------
>                 Key: CAMEL-64
>                 URL:
>             Project: Apache Camel
>          Issue Type: Improvement
>          Components: camel-core
>            Reporter: Hiram Chirino
>            Assignee: Willem Jiang
>             Fix For: 2.0.0
> For example splitter() should be split() and resequencer should be resequence.
> Old methods should be deprecated.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message