camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <>
Subject [jira] Commented: (CAMEL-316) Merge Fault and Exception semantics
Date Tue, 23 Sep 2008 06:24:52 GMT


Claus Ibsen commented on CAMEL-316:

+1 to #3

I suggest to use a header without any minus or dot. We have trouble with these already. And
we consider using a new pattern for Camel 2.0 that James suggested:
"CamelFault" is a better header name.

BTW: We also have a throwFault DSL.

> Merge Fault and Exception semantics
> -----------------------------------
>                 Key: CAMEL-316
>                 URL:
>             Project: Apache Camel
>          Issue Type: Improvement
>            Reporter: Hadrian Zbarcea
>            Assignee: Hadrian Zbarcea
>             Fix For: 2.0.0
> The fact that there are output/fault/exception could be confusing and clutter the dsl,
especially for components where there is no distinction between fault and exception.  We should
merge the two and simplify the model.
> See nabble thread:

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message