camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen" ...@silverbullet.dk>
Subject RE: [VOTE] Release apache-camel-1.4
Date Fri, 27 Jun 2008 10:21:27 GMT
Damm fat fingers.

Also there might be a problem with the old fashion of disabling jmx with useJmx="false" that
might not work and thus enable JMX. 

And Willem has an issue with the loan broaker example.

So I vote -1

Med venlig hilsen
 
Claus Ibsen
......................................
Silverbullet
Skovsgårdsvænget 21
8362 Hørning
Tlf. +45 2962 7576
Web: www.silverbullet.dk

-----Original Message-----
From: Claus Ibsen 
Sent: 27. august 2008 12:20
To: 'camel-dev@activemq.apache.org'
Subject: RE: [VOTE] Release apache-camel-1.4

Hi Gert

Great catch. I do think we should cut a new release next week giving time to fix this issue.
Also there might be a problem with the old fashion disabling jmx

Med venlig hilsen
 
Claus Ibsen
......................................
Silverbullet
Skovsgårdsvænget 21
8362 Hørning
Tlf. +45 2962 7576
Web: www.silverbullet.dk
-----Original Message-----
From: Gert Vanthienen [mailto:gert.vanthienen@skynet.be] 
Sent: 27. juni 2008 10:57
To: camel-dev@activemq.apache.org
Subject: Re: [VOTE] Release apache-camel-1.4

L.S.,

Just found a minor problem in the release: I think the spring.schemas 
files are missing some entries and contain others that shouldn't be there.

An example:  the camel-spring.xsd has everything that's required
http\://activemq.apache.org/camel/schema/spring/camel-spring.xsd=camel-spring.xsd
http\://activemq.apache.org/camel/schema/spring/camel-spring-1.0.0.xsd=camel-spring.xsd
http\://activemq.apache.org/camel/schema/spring/camel-spring-1.1.0.xsd=camel-spring.xsd
http\://activemq.apache.org/camel/schema/spring/camel-spring-1.2.0.xsd=camel-spring.xsd
http\://activemq.apache.org/camel/schema/spring/camel-spring-1.3.0.xsd=camel-spring.xsd
http\://activemq.apache.org/camel/schema/spring/camel-spring-1.4.0.xsd=camel-spring.xsd

... but if you look at the other entries, they seem to be missing some 
things.  An example:
http\://activemq.apache.org/camel/schema/osgi/camel-osgi.xsd=camel-osgi.xsd
http\://activemq.apache.org/camel/schema/osgi/camel-osgi-1.1.xsd=camel-osgi.xsd
http\://activemq.apache.org/camel/schema/osgi/camel-osgi-1.1-SNAPSHOT.xsd=camel-osgi.xsd
http\://activemq.apache.org/camel/schema/osgi/camel-osgi-1.2.xsd=camel-osgi.xsd
http\://activemq.apache.org/camel/schema/osgi/camel-osgi-1.2-SNAPSHOT.xsd=camel-osgi.xsd

I don't think we should put the SNAPSHOTs in there and the latest 
released version camel-osgi-1.3.0.xsd isn't even in there.  Using plain 
Spring, these missing entries can cause Spring to go off to the website 
every time it loads the context just to get the schema or even worse, 
not getting the XSD at all if behind a proxy.  I'll fix it in trunk 
ASAP, but I'm unsure whether it is a release blocker...

Regards,

Gert



Hadrian Zbarcea wrote:
> This is a vote to release camel 1.4
>
> After 2 1/2 months a new Camel is out.  Another fantastic community 
> effort with 179 issues fixed.
> Many thanks for all the hard work!
>
> The staging area is at:
> http://people.apache.org/~hadrian/apache-camel-1.4.0-RC2/maven2
>
> The tarballs are here:
> http://people.apache.org/~hadrian/apache-camel-1.4.0-RC2/maven2/org/apache/camel/apache-camel/1.4.0/

>
>
> Please vote to approve this release binary.  The vote will be open for 
> at least 72 hours.
>
> [ ] +1 Release the binary as Apache Camel 1.4.0
> [ ] -1 Veto the release (provide specific comments)
>
> Here's my +1
> Hadrian


Mime
View raw message