camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Victor Salaman (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CAMEL-301) spring.handlers and spring.schemas are not being merged in the uberjar
Date Mon, 21 Jan 2008 11:37:21 GMT

    [ https://issues.apache.org/activemq/browse/CAMEL-301?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=41097#action_41097
] 

Victor Salaman commented on CAMEL-301:
--------------------------------------

By adding a new transformer this also fixes CAMEL-268 issue:

                                <transformer
                                        implementation="org.apache.maven.plugins.shade.resource.AppendingTransformer">
                                    <resource>META-INF/services/org/apache/camel/TypeConverter</resource>
                                </transformer>


> spring.handlers and spring.schemas are not being merged in the uberjar
> ----------------------------------------------------------------------
>
>                 Key: CAMEL-301
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-301
>             Project: Apache Camel
>          Issue Type: Improvement
>    Affects Versions: 1.2.0, 1.3.0
>            Reporter: Victor Salaman
>            Priority: Minor
>
> The build process is not merging spring.schemas and spring.handlers from the component
modules, rendering some of the spring support useless. Due to this, for a while I've had to
use the individual jars, and all the repetitive maven dependency exclusions in the POM are
just insane! 
> Therefore I've replaced maven-bundle-plugin locally with maven-shade-plugin (now that
beta-1 is released!) such as:
>             <plugin>
>                 <groupId>org.apache.maven.plugins</groupId>
>                 <artifactId>maven-shade-plugin</artifactId>
>                 <version>1.0-beta-1</version>
>                 <executions>
>                     <execution>
>                         <phase>package</phase>
>                         <goals>
>                             <goal>shade</goal>
>                         </goals>
>                         <configuration>
>                             <shadedGroupFilter>org.apache.camel</shadedGroupFilter>
>                             <shadedArtifactAttached>false</shadedArtifactAttached>
>                             <createSourcesJar>false</createSourcesJar>
>                             <promoteTransitiveDependencies>true</promoteTransitiveDependencies>
>                             <createDependencyReducedPom>true</createDependencyReducedPom>
>                             <transformers>
>                                 <transformer implementation="org.apache.maven.plugins.shade.resource.AppendingTransformer">
>                                     <resource>META-INF/spring.handlers</resource>
>                                 </transformer>
>                                 <transformer
>                                         implementation="org.apache.maven.plugins.shade.resource.AppendingTransformer">
>                                     <resource>META-INF/spring.schemas</resource>
>                                 </transformer>
>                             </transformers>
>                         </configuration>
>                     </execution>
>                 </executions>
>             </plugin>
> and now it works properly (but now is not a osgi bundle!). I don't really know if the
bundle plugin is able to append resources, but it'd be nice if we fixed this before 1.3 is
released.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message