camel-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zregv...@apache.org
Subject [camel] 05/06: CAMEL-12618: upgrade Groovy Eclipse compiler
Date Thu, 23 Aug 2018 13:18:10 GMT
This is an automated email from the ASF dual-hosted git repository.

zregvart pushed a commit to branch java-10-test
in repository https://gitbox.apache.org/repos/asf/camel.git

commit 49e07124f2ee8bb6eb3722a3195451c56dedbd25
Author: Zoran Regvart <zregvart@apache.org>
AuthorDate: Thu Aug 23 10:56:33 2018 +0200

    CAMEL-12618: upgrade Groovy Eclipse compiler
---
 archetypes/camel-archetype-groovy/pom.xml                   | 13 ++++++++++++-
 .../src/main/resources/archetype-resources/pom.xml          |  4 ++--
 components/camel-grape/pom.xml                              |  8 +++-----
 components/camel-groovy-dsl/pom.xml                         |  4 ++--
 examples/camel-example-groovy/pom.xml                       |  4 ++--
 parent/pom.xml                                              |  7 ++-----
 6 files changed, 23 insertions(+), 17 deletions(-)

diff --git a/archetypes/camel-archetype-groovy/pom.xml b/archetypes/camel-archetype-groovy/pom.xml
index 88d596f..e88d843 100644
--- a/archetypes/camel-archetype-groovy/pom.xml
+++ b/archetypes/camel-archetype-groovy/pom.xml
@@ -46,7 +46,7 @@
     <resources>
       <resource>
         <directory>src/main/resources</directory>
-        <filtering>false</filtering>
+        <filtering>true</filtering>
       </resource>
       <resource>
         <directory>src/main/resources-filtered</directory>
@@ -56,6 +56,17 @@
         </includes>
       </resource>
     </resources>
+    <plugins>
+      <plugin>
+        <artifactId>maven-resources-plugin</artifactId>
+        <configuration>
+            <useDefaultDelimiters>false</useDefaultDelimiters>
+            <delimiters>
+                <delimiter>@</delimiter>
+            </delimiters>
+        </configuration>
+      </plugin>
+    </plugins>
   </build>
 
 </project>
diff --git a/archetypes/camel-archetype-groovy/src/main/resources/archetype-resources/pom.xml
b/archetypes/camel-archetype-groovy/src/main/resources/archetype-resources/pom.xml
index ed27546..18b945b 100644
--- a/archetypes/camel-archetype-groovy/src/main/resources/archetype-resources/pom.xml
+++ b/archetypes/camel-archetype-groovy/src/main/resources/archetype-resources/pom.xml
@@ -114,7 +114,7 @@
           <dependency>
             <groupId>org.codehaus.groovy</groupId>
             <artifactId>groovy-eclipse-compiler</artifactId>
-            <version>2.9.2-01</version>
+            <version>@groovy-eclipse-compiler-version@</version>
             <exclusions>
               <exclusion>
                 <groupId>org.codehaus.groovy</groupId>
@@ -125,7 +125,7 @@
           <dependency>
             <groupId>org.codehaus.groovy</groupId>
             <artifactId>groovy-eclipse-batch</artifactId>
-            <version>2.4.3-01</version>
+            <version>@groovy-eclipse-batch-version@</version>
           </dependency>
         </dependencies>
       </plugin>
diff --git a/components/camel-grape/pom.xml b/components/camel-grape/pom.xml
index e408f6d..811d5ac 100644
--- a/components/camel-grape/pom.xml
+++ b/components/camel-grape/pom.xml
@@ -32,8 +32,6 @@
   <description>The grape component allows you to fetch, load and manage additional
jars when CamelContext is running</description>
 
   <properties>
-    <groovy-eclipse-batch.version>2.4.3-01</groovy-eclipse-batch.version>
-    <groovy-eclipse-compiler.version>2.9.2-01</groovy-eclipse-compiler.version>
     <plexus-compiler-api.version>2.8.3</plexus-compiler-api.version>
     <camel.osgi.export.pkg />
   </properties>
@@ -95,12 +93,12 @@
           <dependency>
             <groupId>org.codehaus.groovy</groupId>
             <artifactId>groovy-eclipse-batch</artifactId>
-            <version>${groovy-eclipse-batch.version}</version>
+            <version>${groovy-eclipse-batch-version}</version>
           </dependency>
           <dependency>
             <groupId>org.codehaus.groovy</groupId>
             <artifactId>groovy-eclipse-compiler</artifactId>
-            <version>${groovy-eclipse-compiler.version}</version>
+            <version>${groovy-eclipse-compiler-version}</version>
           </dependency>
           <dependency>
             <groupId>org.codehaus.plexus</groupId>
@@ -115,7 +113,7 @@
       <plugin>
         <groupId>org.codehaus.groovy</groupId>
         <artifactId>groovy-eclipse-compiler</artifactId>
-        <version>${groovy-eclipse-compiler.version}</version>
+        <version>${groovy-eclipse-compiler-version}</version>
         <extensions>true</extensions>
       </plugin>
       <plugin>
diff --git a/components/camel-groovy-dsl/pom.xml b/components/camel-groovy-dsl/pom.xml
index 62ac12a..79db32a 100644
--- a/components/camel-groovy-dsl/pom.xml
+++ b/components/camel-groovy-dsl/pom.xml
@@ -138,7 +138,7 @@
           <dependency>
             <groupId>org.codehaus.groovy</groupId>
             <artifactId>groovy-eclipse-compiler</artifactId>
-            <version>2.9.2-01</version>
+            <version>${groovy-eclipse-compiler-version}</version>
             <exclusions>
               <exclusion>
                 <groupId>org.codehaus.groovy</groupId>
@@ -149,7 +149,7 @@
           <dependency>
             <groupId>org.codehaus.groovy</groupId>
             <artifactId>groovy-eclipse-batch</artifactId>
-            <version>2.4.3-01</version>
+            <version>${groovy-eclipse-batch-version}</version>
           </dependency>
         </dependencies>
       </plugin>
diff --git a/examples/camel-example-groovy/pom.xml b/examples/camel-example-groovy/pom.xml
index 577f398..c26933b 100644
--- a/examples/camel-example-groovy/pom.xml
+++ b/examples/camel-example-groovy/pom.xml
@@ -97,7 +97,7 @@
           <dependency>
             <groupId>org.codehaus.groovy</groupId>
             <artifactId>groovy-eclipse-compiler</artifactId>
-            <version>2.9.2-01</version>
+            <version>${groovy-eclipse-compiler-version}</version>
             <exclusions>
               <exclusion>
                 <groupId>org.codehaus.groovy</groupId>
@@ -108,7 +108,7 @@
           <dependency>
             <groupId>org.codehaus.groovy</groupId>
             <artifactId>groovy-eclipse-batch</artifactId>
-            <version>2.4.3-01</version>
+            <version>${groovy-eclipse-batch-version}</version>
           </dependency>
         </dependencies>
       </plugin>
diff --git a/parent/pom.xml b/parent/pom.xml
index 43284f3..cde2ffe 100644
--- a/parent/pom.xml
+++ b/parent/pom.xml
@@ -255,19 +255,17 @@
     <geronimo-json-spec-version>1.0</geronimo-json-spec-version>
     <geronimo-jta-spec-version>1.1.1</geronimo-jta-spec-version>
     <geronimo-servlet-spec-version>1.0</geronimo-servlet-spec-version>
-    <geronimo-servlet-2.5-spec-version>1.2</geronimo-servlet-2.5-spec-version>
     <geronimo-ws-metadata-spec-version>1.1.3</geronimo-ws-metadata-spec-version>
     <gmetric4j-version>1.0.10</gmetric4j-version>
-    <google-guava-version>19.0</google-guava-version>
     <google-api-client-version>1.22.0</google-api-client-version>
     <google-api-services-drive-version>v2-rev297-1.22.0</google-api-services-drive-version>
-    <google-api-services-calendar-version>v3-rev291-1.22.0</google-api-services-calendar-version>
     <google-api-services-mail-version>v1-rev81-1.22.0</google-api-services-mail-version>
-    <google-api-services-bigquery-version>v2-rev352-1.22.0</google-api-services-bigquery-version>
     <google-api-services-pubsub-version>v1-rev12-1.22.0</google-api-services-pubsub-version>
     <google-mail-guava-version>17.0</google-mail-guava-version>
     <google-truth-version>0.30</google-truth-version>
     <grizzly-websockets-version>2.3.25</grizzly-websockets-version>
+    <groovy-eclipse-compiler-version>3.0.0-01</groovy-eclipse-compiler-version>
+    <groovy-eclipse-batch-version>2.5.2-01</groovy-eclipse-batch-version>
     <grpc-version>1.14.0</grpc-version>
     <grpc-google-auth-library-version>0.9.0</grpc-google-auth-library-version>
     <grpc-guava-version>20.0</grpc-guava-version>
@@ -278,7 +276,6 @@
     <gson-version>2.8.5</gson-version>
     <guice-version>4.0</guice-version>
     <guice3-version>3.0</guice3-version>
-    <guice-bundle-version>3.0_1</guice-bundle-version>
     <hadoop-bundle-version>1.2.1_1</hadoop-bundle-version>
     <hadoop-version>1.2.1</hadoop-version>
     <hadoop2-bundle-version>2.7.2_1</hadoop2-bundle-version>


Mime
View raw message