camel-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nferr...@apache.org
Subject [3/5] camel git commit: CAMEL-10435: move spring-boot-dm to platforms dir
Date Fri, 04 Nov 2016 08:32:37 GMT
http://git-wip-us.apache.org/repos/asf/camel/blob/a15cbb47/platforms/spring-boot/spring-boot-dm/camel-spring-boot-generator-bom/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/spring-boot-dm/camel-spring-boot-generator-bom/pom.xml
b/platforms/spring-boot/spring-boot-dm/camel-spring-boot-generator-bom/pom.xml
new file mode 100644
index 0000000..fa78ee5
--- /dev/null
+++ b/platforms/spring-boot/spring-boot-dm/camel-spring-boot-generator-bom/pom.xml
@@ -0,0 +1,294 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!--
+  Licensed to the Apache Software Foundation (ASF) under one or more
+  contributor license agreements.  See the NOTICE file distributed with
+  this work for additional information regarding copyright ownership.
+  The ASF licenses this file to You under the Apache License, Version 2.0
+  (the "License"); you may not use this file except in compliance with
+  the License.  You may obtain a copy of the License at
+
+  http://www.apache.org/licenses/LICENSE-2.0
+
+  Unless required by applicable law or agreed to in writing, software
+  distributed under the License is distributed on an "AS IS" BASIS,
+  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+  See the License for the specific language governing permissions and
+  limitations under the License.
+-->
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+    <parent>
+        <artifactId>camel-spring-boot-dm</artifactId>
+        <groupId>org.apache.camel</groupId>
+        <version>2.19.0-SNAPSHOT</version>
+    </parent>
+    <modelVersion>4.0.0</modelVersion>
+
+    <artifactId>camel-spring-boot-generator-bom</artifactId>
+    <packaging>pom</packaging>
+    <name>Camel :: Platforms :: Spring-Boot :: Dependency Management :: BOM Generator</name>
+    <description>Camel Spring-Boot BOM Generator</description>
+
+    <dependencyManagement>
+
+        <dependencies>
+
+            <!-- Additional libraries related to Avro (version from Camel) -->
+            <dependency>
+                <groupId>org.apache.avro</groupId>
+                <artifactId>avro-mapred</artifactId>
+                <version>${avro-version}</version>
+            </dependency>
+            <dependency>
+                <groupId>org.apache.avro</groupId>
+                <artifactId>avro-mapred</artifactId>
+                <classifier>hadoop2</classifier>
+                <version>${avro-version}</version>
+            </dependency>
+
+
+            <!-- Add a uniform jackson 1 (version from Camel) -->
+            <dependency>
+                <groupId>org.codehaus.jackson</groupId>
+                <artifactId>jackson-core</artifactId>
+                <version>${jackson-version}</version>
+            </dependency>
+            <dependency>
+                <groupId>org.codehaus.jackson</groupId>
+                <artifactId>jackson-core-asl</artifactId>
+                <version>${jackson-version}</version>
+            </dependency>
+            <dependency>
+                <groupId>org.codehaus.jackson</groupId>
+                <artifactId>jackson-jaxrs</artifactId>
+                <version>${jackson-version}</version>
+            </dependency>
+            <dependency>
+                <groupId>org.codehaus.jackson</groupId>
+                <artifactId>jackson-mapper-asl</artifactId>
+                <version>${jackson-version}</version>
+            </dependency>
+            <dependency>
+                <groupId>org.codehaus.jackson</groupId>
+                <artifactId>jackson-xc</artifactId>
+                <version>${jackson-version}</version>
+            </dependency>
+
+            <!-- Added to match the version of related libraries provided by spring-boot
-->
+            <dependency>
+                <groupId>com.hazelcast</groupId>
+                <artifactId>hazelcast-client</artifactId>
+                <version>${hazelcast-version}</version>
+            </dependency>
+
+            <!-- Added to match the version of related libraries provided by spring-boot
-->
+            <dependency>
+                <groupId>org.slf4j</groupId>
+                <artifactId>slf4j-ext</artifactId>
+                <version>${slf4j-version}</version>
+            </dependency>
+
+            <!-- Added to match the version of related libraries provided by spring-boot
-->
+            <dependency>
+                <groupId>net.java.dev.jna</groupId>
+                <artifactId>jna-platform</artifactId>
+                <version>${jna-version}</version>
+            </dependency>
+
+            <!-- Added to match the version of related libraries provided by spring-boot
-->
+            <!-- Seems that htmlunit 2.21 is not present in Maven central -->
+            <!--<dependency>-->
+                <!--<groupId>net.sourceforge.htmlunit</groupId>-->
+                <!--<artifactId>htmlunit-core-js</artifactId>-->
+                <!--<version>${htmlunit-version}</version>-->
+            <!--</dependency>-->
+
+            <!-- Added to match the version of related libraries provided by spring-boot
-->
+            <dependency>
+                <groupId>org.eclipse.jetty</groupId>
+                <artifactId>jetty-util-ajax</artifactId>
+                <version>${jetty-version}</version>
+            </dependency>
+            <dependency>
+                <groupId>org.eclipse.jetty</groupId>
+                <artifactId>jetty-rewrite</artifactId>
+                <version>${jetty-version}</version>
+            </dependency>
+
+            <!-- Added to match the version of related libraries provided by spring-boot
-->
+            <dependency>
+                <groupId>org.eclipse.jetty.websocket</groupId>
+                <artifactId>websocket-api</artifactId>
+                <version>${jetty-version}</version>
+            </dependency>
+            <dependency>
+                <groupId>org.eclipse.jetty.websocket</groupId>
+                <artifactId>websocket-common</artifactId>
+                <version>${jetty-version}</version>
+            </dependency>
+            <dependency>
+                <groupId>org.eclipse.jetty.websocket</groupId>
+                <artifactId>websocket-servlet</artifactId>
+                <version>${jetty-version}</version>
+            </dependency>
+
+            <!-- Added to match the version of related libraries provided by Spring-boot
-->
+            <dependency>
+                <groupId>com.fasterxml.jackson.module</groupId>
+                <artifactId>jackson-module-scala_2.11</artifactId>
+                <version>${scala-jackson2-version}</version>
+            </dependency>
+
+
+            <!-- Dependencies from Camel parent at the end -->
+            <dependency>
+                <groupId>org.apache.camel</groupId>
+                <artifactId>camel-parent</artifactId>
+                <version>${project.version}</version>
+                <type>pom</type>
+                <scope>import</scope>
+            </dependency>
+
+        </dependencies>
+    </dependencyManagement>
+
+    <build>
+        <plugins>
+            <plugin>
+                <groupId>org.apache.camel</groupId>
+                <artifactId>bom-generator-maven-plugin</artifactId>
+                <version>${project.version}</version>
+                <executions>
+                    <execution>
+                        <goals>
+                            <goal>generate</goal>
+                        </goals>
+                    </execution>
+                </executions>
+                <configuration>
+                    <checkConflicts>
+                        <boms>
+                            <bom>
+                                <groupId>org.springframework.boot</groupId>
+                                <artifactId>spring-boot-dependencies</artifactId>
+                                <version>${spring-boot-version}</version>
+                            </bom>
+                            <!-- Other BOMs imported by SB should be listed explicitly
-->
+                            <bom>
+                                <groupId>org.springframework</groupId>
+                                <artifactId>spring-framework-bom</artifactId>
+                                <version>${spring-version}</version>
+                            </bom>
+                            <bom>
+                                <groupId>org.springframework.data</groupId>
+                                <artifactId>spring-data-releasetrain</artifactId>
+                                <version>${spring-data-releasetrain-version}</version>
+                            </bom>
+                            <bom>
+                                <groupId>org.springframework.integration</groupId>
+                                <artifactId>spring-integration-bom</artifactId>
+                                <version>${spring-integration-version}</version>
+                            </bom>
+                            <bom>
+                                <groupId>org.springframework.security</groupId>
+                                <artifactId>spring-security-bom</artifactId>
+                                <version>${spring-security-version}</version>
+                            </bom>
+                        </boms>
+                    </checkConflicts>
+                    <dependencies>
+                        <includes>
+                            <include>*:*</include>
+                        </includes>
+                        <excludes>
+
+                            <!-- These artifacts should not be included in the final (generated)
BOM -->
+
+                            <!-- Different versions from the ones provided by spring-boot
-->
+                            <exclude>de.flapdoodle*:*</exclude>
+                            <exclude>org.apache.activemq:*</exclude>
+                            <exclude>org.apache.commons:commons-pool2</exclude>
+                            <exclude>org.apache.httpcomponents:httpasyncclient</exclude>
+                            <exclude>org.apache.httpcomponents:httpclient</exclude>
+                            <exclude>org.apache.httpcomponents:httpclient-cache</exclude>
+                            <exclude>org.apache.httpcomponents:httpclient-osgi</exclude>
+                            <exclude>org.apache.httpcomponents:httpcore</exclude>
+                            <exclude>org.apache.httpcomponents:httpmime</exclude>
+                            <exclude>org.apache.derby:derby</exclude>
+                            <exclude>org.apache.logging.log4j:*</exclude>
+                            <exclude>org.cassandraunit:*</exclude>
+                            <exclude>org.codehaus.groovy:*</exclude>
+                            <exclude>org.hibernate:hibernate-entitymanager</exclude>
+                            <exclude>org.hsqldb:*</exclude>
+                            <exclude>org.mockito:*</exclude>
+
+                            <exclude>org.slf4j:jul-to-slf4j</exclude>
+                            <exclude>org.slf4j:log4j-over-slf4j</exclude>
+                            <exclude>org.slf4j:slf4j-api</exclude>
+                            <exclude>org.slf4j:slf4j-log4j12</exclude>
+                            <exclude>org.slf4j:slf4j-simple</exclude>
+
+                            <exclude>org.springframework*:*</exclude>
+
+                            <exclude>commons-codec:*</exclude>
+                            <exclude>commons-collections:*</exclude>
+                            <exclude>commons-dbcp:*</exclude>
+                            <exclude>commons-pool:*</exclude>
+
+                            <exclude>com.github.ben-manes.caffeine:caffeine</exclude>
+                            <exclude>com.datastax.cassandra:*</exclude>
+
+                            <exclude>com.fasterxml.jackson.core:jackson-annotations</exclude>
+                            <exclude>com.fasterxml.jackson.core:jackson-core</exclude>
+                            <exclude>com.fasterxml.jackson.core:jackson-databind</exclude>
+                            <exclude>com.fasterxml.jackson.dataformat:jackson-dataformat-cbor</exclude>
+                            <exclude>com.fasterxml.jackson.dataformat:jackson-dataformat-smile</exclude>
+                            <exclude>com.fasterxml.jackson.dataformat:jackson-dataformat-xml</exclude>
+                            <exclude>com.fasterxml.jackson.dataformat:jackson-dataformat-yaml</exclude>
+                            <exclude>com.fasterxml.jackson.datatype:jackson-datatype-jaxrs</exclude>
+                            <exclude>com.fasterxml.jackson.datatype:jackson-datatype-joda</exclude>
+                            <exclude>com.fasterxml.jackson.jaxrs:jackson-jaxrs-base</exclude>
+                            <exclude>com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider</exclude>
+                            <exclude>com.fasterxml.jackson.module:jackson-module-jaxb-annotations</exclude>
+
+                            <exclude>com.google.code.gson:*</exclude>
+                            <exclude>javax.servlet:javax.servlet-api</exclude>
+                            <exclude>junit:*</exclude>
+                            <exclude>net.sf.ehcache:ehcache</exclude>
+
+                            <exclude>xml-apis:*</exclude>
+
+                            <!-- Different versions required by some modules -->
+                            <exclude>com.google.inject:*</exclude>
+                            <exclude>com.google.guava:*</exclude>
+                            <exclude>io.netty*:*</exclude>
+                            <exclude>org.scala-lang:*</exclude>
+                            <exclude>org.apache.lucene:*</exclude>
+
+
+                            <!-- Unrelated -->
+                            <exclude>org.apache.servicemix.bundles:*</exclude>
+                            <exclude>org.ops4j.pax*:*</exclude>
+                            <exclude>org.codehaus.mojo:*</exclude>
+                            <exclude>org.apache.servicemix:*</exclude>
+                            <exclude>org.apache.aries.blueprint:*</exclude>
+                            <exclude>org.apache.felix:*</exclude>
+                            <exclude>org.apache.maven.archetype:*</exclude>
+                            <exclude>org.osgi:*</exclude>
+
+                            <!-- Unuseful -->
+                            <exclude>org.springframework:springloaded</exclude>
+                            <exclude>com.zaxxer:HikariCP-java6</exclude>
+                        </excludes>
+                    </dependencies>
+
+                    <sourcePom>${basedir}/src/main/resources/target-template-pom.xml</sourcePom>
+                    <targetPom>${basedir}/../camel-spring-boot-dependencies/pom.xml</targetPom>
+                </configuration>
+
+            </plugin>
+        </plugins>
+    </build>
+
+</project>

http://git-wip-us.apache.org/repos/asf/camel/blob/a15cbb47/platforms/spring-boot/spring-boot-dm/camel-spring-boot-generator-bom/src/main/resources/target-template-pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/spring-boot-dm/camel-spring-boot-generator-bom/src/main/resources/target-template-pom.xml
b/platforms/spring-boot/spring-boot-dm/camel-spring-boot-generator-bom/src/main/resources/target-template-pom.xml
new file mode 100644
index 0000000..9ef2068
--- /dev/null
+++ b/platforms/spring-boot/spring-boot-dm/camel-spring-boot-generator-bom/src/main/resources/target-template-pom.xml
@@ -0,0 +1,50 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!--
+  Licensed to the Apache Software Foundation (ASF) under one or more
+  contributor license agreements.  See the NOTICE file distributed with
+  this work for additional information regarding copyright ownership.
+  The ASF licenses this file to You under the Apache License, Version 2.0
+  (the "License"); you may not use this file except in compliance with
+  the License.  You may obtain a copy of the License at
+
+  http://www.apache.org/licenses/LICENSE-2.0
+
+  Unless required by applicable law or agreed to in writing, software
+  distributed under the License is distributed on an "AS IS" BASIS,
+  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+  See the License for the specific language governing permissions and
+  limitations under the License.
+-->
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+    <parent>
+        <artifactId>camel-spring-boot-dm</artifactId>
+        <groupId>org.apache.camel</groupId>
+        <version>${project.version}</version>
+    </parent>
+    <modelVersion>4.0.0</modelVersion>
+
+    <artifactId>camel-spring-boot-dependencies</artifactId>
+    <packaging>pom</packaging>
+    <name>Camel :: Spring-Boot :: Dependency Management :: BOM</name>
+    <description>Camel Spring-Boot BOM</description>
+
+    <dependencyManagement>
+        <dependencies>
+            <!-- To be filled in -->
+        </dependencies>
+    </dependencyManagement>
+
+    <!-- Force the reactor build order -->
+    <dependencies>
+        <dependency>
+            <groupId>org.apache.camel</groupId>
+            <artifactId>camel-spring-boot-generator-bom</artifactId>
+            <version>${project.version}</version>
+            <type>pom</type>
+            <scope>provided</scope>
+        </dependency>
+    </dependencies>
+
+</project>
\ No newline at end of file

http://git-wip-us.apache.org/repos/asf/camel/blob/a15cbb47/platforms/spring-boot/spring-boot-dm/camel-starter-parent/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/spring-boot-dm/camel-starter-parent/pom.xml b/platforms/spring-boot/spring-boot-dm/camel-starter-parent/pom.xml
new file mode 100644
index 0000000..c83c101
--- /dev/null
+++ b/platforms/spring-boot/spring-boot-dm/camel-starter-parent/pom.xml
@@ -0,0 +1,169 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!--
+  Licensed to the Apache Software Foundation (ASF) under one or more
+  contributor license agreements.  See the NOTICE file distributed with
+  this work for additional information regarding copyright ownership.
+  The ASF licenses this file to You under the Apache License, Version 2.0
+  (the "License"); you may not use this file except in compliance with
+  the License.  You may obtain a copy of the License at
+
+  http://www.apache.org/licenses/LICENSE-2.0
+
+  Unless required by applicable law or agreed to in writing, software
+  distributed under the License is distributed on an "AS IS" BASIS,
+  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+  See the License for the specific language governing permissions and
+  limitations under the License.
+-->
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+    <parent>
+        <artifactId>camel-spring-boot-dm</artifactId>
+        <groupId>org.apache.camel</groupId>
+        <version>2.19.0-SNAPSHOT</version>
+    </parent>
+    <modelVersion>4.0.0</modelVersion>
+
+    <artifactId>camel-starter-parent</artifactId>
+    <packaging>pom</packaging>
+    <name>Camel :: Platforms :: Spring-Boot :: Dependency Management :: Starter Parent</name>
+    <description>Camel Spring-Boot Starters Parent POM</description>
+
+    <dependencies>
+        <!-- Dependencies added for all starters -->
+
+        <!-- Logback is the default logging implementation in spring-boot but it doesn't
provide the log4j2 binding -->
+        <!-- Not a problem for now -->
+        <!--<dependency>-->
+            <!--<groupId>org.apache.logging.log4j</groupId>-->
+            <!--<artifactId>log4j-to-slf4j</artifactId>-->
+            <!--<version>${log4j2-version}</version>-->
+        <!--</dependency>-->
+
+        <!-- Force the reactor build order -->
+        <dependency>
+            <groupId>org.apache.camel</groupId>
+            <artifactId>camel-spring-boot-dependencies</artifactId>
+            <version>${project.version}</version>
+            <type>pom</type>
+            <scope>provided</scope>
+        </dependency>
+
+    </dependencies>
+
+    <dependencyManagement>
+
+        <dependencies>
+
+            <!-- The spring-boot dependencies will be used by end users, so it's ok to
use it in the parent -->
+            <dependency>
+                <groupId>org.springframework.boot</groupId>
+                <artifactId>spring-boot-dependencies</artifactId>
+                <version>${spring-boot-version}</version>
+                <type>pom</type>
+                <scope>import</scope>
+            </dependency>
+
+            <!-- What's in the user BOM is OK for the parent -->
+            <dependency>
+                <groupId>org.apache.camel</groupId>
+                <artifactId>camel-spring-boot-dependencies</artifactId>
+                <version>${project.version}</version>
+                <type>pom</type>
+                <scope>import</scope>
+            </dependency>
+
+            <!-- Testing -->
+            <dependency>
+                <groupId>org.jboss.arquillian.junit</groupId>
+                <artifactId>arquillian-junit-container</artifactId>
+                <version>${arquillian-version}</version>
+                <scope>test</scope>
+            </dependency>
+
+            <!-- Forcing Hadoop in starters -->
+            <dependency>
+                <groupId>org.apache.hadoop</groupId>
+                <artifactId>hadoop-common</artifactId>
+                <version>${hadoop2-version}</version>
+            </dependency>
+            <dependency>
+                <groupId>org.apache.hadoop</groupId>
+                <artifactId>hadoop-auth</artifactId>
+                <version>${hadoop2-version}</version>
+            </dependency>
+            <dependency>
+                <groupId>org.apache.hadoop</groupId>
+                <artifactId>hadoop-mapreduce-client-core</artifactId>
+                <version>${hadoop2-version}</version>
+            </dependency>
+            <dependency>
+                <groupId>org.apache.hadoop</groupId>
+                <artifactId>hadoop-yarn-common</artifactId>
+                <version>${hadoop2-version}</version>
+            </dependency>
+            <dependency>
+                <groupId>org.apache.hadoop</groupId>
+                <artifactId>hadoop-annotations</artifactId>
+                <version>${hadoop2-version}</version>
+            </dependency>
+            <dependency>
+                <groupId>org.apache.hadoop</groupId>
+                <artifactId>hadoop-hdfs</artifactId>
+                <version>${hadoop2-version}</version>
+            </dependency>
+
+            <!-- Netty cannot be forced at the moment -->
+
+            <!--<dependency>-->
+                <!--<groupId>io.netty</groupId>-->
+                <!--<artifactId>netty-all</artifactId>-->
+                <!--<version>${netty-version}</version>-->
+            <!--</dependency>-->
+            <!--<dependency>-->
+                <!--<groupId>io.netty</groupId>-->
+                <!--<artifactId>netty-buffer</artifactId>-->
+                <!--<version>${netty-version}</version>-->
+            <!--</dependency>-->
+            <!--<dependency>-->
+                <!--<groupId>io.netty</groupId>-->
+                <!--<artifactId>netty-codec-http</artifactId>-->
+                <!--<version>${netty-version}</version>-->
+            <!--</dependency>-->
+            <!--<dependency>-->
+                <!--<groupId>io.netty</groupId>-->
+                <!--<artifactId>netty-codec</artifactId>-->
+                <!--<version>${netty-version}</version>-->
+            <!--</dependency>-->
+            <!--<dependency>-->
+                <!--<groupId>io.netty</groupId>-->
+                <!--<artifactId>netty-handler</artifactId>-->
+                <!--<version>${netty-version}</version>-->
+            <!--</dependency>-->
+            <!--<dependency>-->
+                <!--<groupId>io.netty</groupId>-->
+                <!--<artifactId>netty-transport-native-epoll</artifactId>-->
+                <!--<classifier>linux-x86_64</classifier>-->
+                <!--<version>${netty-version}</version>-->
+            <!--</dependency>-->
+            <!--<dependency>-->
+                <!--<groupId>io.netty</groupId>-->
+                <!--<artifactId>netty-common</artifactId>-->
+                <!--<version>${netty-version}</version>-->
+            <!--</dependency>-->
+            <!--<dependency>-->
+                <!--<groupId>io.netty</groupId>-->
+                <!--<artifactId>netty-resolver</artifactId>-->
+                <!--<version>${netty-version}</version>-->
+            <!--</dependency>-->
+            <!--<dependency>-->
+                <!--<groupId>io.netty</groupId>-->
+                <!--<artifactId>netty-transport</artifactId>-->
+                <!--<version>${netty-version}</version>-->
+            <!--</dependency>-->
+
+        </dependencies>
+    </dependencyManagement>
+
+</project>

http://git-wip-us.apache.org/repos/asf/camel/blob/a15cbb47/platforms/spring-boot/spring-boot-dm/pom.xml
----------------------------------------------------------------------
diff --git a/platforms/spring-boot/spring-boot-dm/pom.xml b/platforms/spring-boot/spring-boot-dm/pom.xml
new file mode 100644
index 0000000..279842f
--- /dev/null
+++ b/platforms/spring-boot/spring-boot-dm/pom.xml
@@ -0,0 +1,155 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!--
+  Licensed to the Apache Software Foundation (ASF) under one or more
+  contributor license agreements.  See the NOTICE file distributed with
+  this work for additional information regarding copyright ownership.
+  The ASF licenses this file to You under the Apache License, Version 2.0
+  (the "License"); you may not use this file except in compliance with
+  the License.  You may obtain a copy of the License at
+
+  http://www.apache.org/licenses/LICENSE-2.0
+
+  Unless required by applicable law or agreed to in writing, software
+  distributed under the License is distributed on an "AS IS" BASIS,
+  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+  See the License for the specific language governing permissions and
+  limitations under the License.
+-->
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+    <parent>
+        <artifactId>spring-boot</artifactId>
+        <groupId>org.apache.camel</groupId>
+        <version>2.19.0-SNAPSHOT</version>
+    </parent>
+
+    <modelVersion>4.0.0</modelVersion>
+    <artifactId>camel-spring-boot-dm</artifactId>
+    <packaging>pom</packaging>
+
+    <name>Camel :: Platforms :: Spring-Boot :: Dependency Management</name>
+    <description>Camel Spring-Boot Dependency Management POM</description>
+    <modules>
+        <module>camel-spring-boot-generator-bom</module>
+        <module>camel-spring-boot-dependencies</module>
+        <module>camel-starter-parent</module>
+    </modules>
+
+    <properties>
+        <!-- Spring-Boot target version -->
+        <spring-boot-version>1.4.1.RELEASE</spring-boot-version>
+
+        <!-- The following dependencies should be aligned with the ones in standard camel
parent -->
+        <avro-version>1.8.1</avro-version>
+        <cassandra-driver-guava-version>18.0</cassandra-driver-guava-version>
+        <jackson-version>1.9.12</jackson-version>
+
+        <egit-github-core-version>2.1.5</egit-github-core-version>
+        <google-guava-version>19.0</google-guava-version>
+        <lucene3-version>3.6.0</lucene3-version>
+        <scala-version>2.11.7</scala-version>
+        <scalaxml-version>1.0.4</scalaxml-version>
+
+        <maven-checkstyle-plugin-version>2.17</maven-checkstyle-plugin-version>
+        <maven-checkstyle-version>6.17</maven-checkstyle-version>
+
+        <arquillian-version>1.1.11.Final</arquillian-version>
+        <hadoop2-version>2.7.2</hadoop2-version>
+
+        <!-- Custom dependency required by some modules -->
+        <ahc-netty-version>4.0.40.Final</ahc-netty-version>
+        <cassandra-netty-version-testing>4.0.37.Final</cassandra-netty-version-testing>
+
+        <!-- The following versions should be aligned with the ones in spring-boot-repo/spring-boot-dependencies/pom.xml
(for the targeted version of spring-boot) -->
+        <jackson2-version>2.8.3</jackson2-version>
+        <scala-jackson2-version>2.8.2</scala-jackson2-version>
+        <jetty9-version>9.3.11.v20160721</jetty9-version>
+        <jetty-version>${jetty9-version}</jetty-version>
+        <jna-version>4.2.2</jna-version>
+        <hazelcast-version>3.6.5</hazelcast-version>
+        <htmlunit-version>2.21</htmlunit-version>
+        <log4j2-version>2.6.2</log4j2-version>
+        <slf4j-version>1.7.21</slf4j-version>
+        <spring-version>4.3.3.RELEASE</spring-version>
+        <spring-data-releasetrain-version>Hopper-SR3</spring-data-releasetrain-version>
+        <spring-integration-version>4.3.2.RELEASE</spring-integration-version>
+        <spring-security-version>4.1.3.RELEASE</spring-security-version>
+    </properties>
+
+    <build>
+        <plugins>
+
+            <plugin>
+                <groupId>org.apache.maven.plugins</groupId>
+                <artifactId>maven-checkstyle-plugin</artifactId>
+                <version>${maven-checkstyle-plugin-version}</version>
+                <dependencies>
+                    <dependency>
+                        <groupId>org.apache.camel</groupId>
+                        <artifactId>camel-buildtools</artifactId>
+                        <version>${project.version}</version>
+                    </dependency>
+                    <dependency>
+                        <groupId>com.puppycrawl.tools</groupId>
+                        <artifactId>checkstyle</artifactId>
+                        <version>${maven-checkstyle-version}</version>
+                    </dependency>
+                </dependencies>
+                <executions>
+                    <execution>
+                        <id>validate</id>
+                        <phase>validate</phase>
+                        <configuration>
+                            <includeResources>false</includeResources>
+                            <configLocation>camel-checkstyle.xml</configLocation>
+                            <consoleOutput>true</consoleOutput>
+                            <failsOnError>true</failsOnError>
+                            <linkXRef>false</linkXRef>
+                            <suppressionsLocation>camel-checkstyle-suppressions.xml</suppressionsLocation>
+                            <encoding>UTF-8</encoding>
+                            <sourceDirectory>${basedir}/src</sourceDirectory>
+                            <excludes>**/archetype-resources/**/*.java</excludes>
+                        </configuration>
+                        <goals>
+                            <goal>checkstyle</goal>
+                        </goals>
+                    </execution>
+                </executions>
+            </plugin>
+            <plugin>
+                <groupId>org.apache.maven.plugins</groupId>
+                <artifactId>maven-compiler-plugin</artifactId>
+                <version>${maven-compiler-plugin-version}</version>
+                <configuration>
+                    <source>${jdk.version}</source>
+                    <target>${jdk.version}</target>
+                    <maxmem>512M</maxmem>
+                    <fork>${compiler.fork}</fork>
+                </configuration>
+            </plugin>
+            <plugin>
+                <groupId>org.apache.maven.plugins</groupId>
+                <artifactId>maven-javadoc-plugin</artifactId>
+                <configuration>
+                    <attach>true</attach>
+                    <source>${jdk.version}</source>
+                    <quiet>true</quiet>
+                    <bottom>Apache Camel</bottom>
+                    <detectOfflineLinks>false</detectOfflineLinks>
+                    <javadocVersion>${jdk.version}</javadocVersion>
+                    <encoding>UTF-8</encoding>
+                </configuration>
+            </plugin>
+            <plugin>
+                <groupId>org.apache.maven.plugins</groupId>
+                <artifactId>maven-resources-plugin</artifactId>
+                <configuration>
+                    <encoding>UTF-8</encoding>
+                </configuration>
+            </plugin>
+
+        </plugins>
+    </build>
+
+</project>

http://git-wip-us.apache.org/repos/asf/camel/blob/a15cbb47/pom.xml
----------------------------------------------------------------------
diff --git a/pom.xml b/pom.xml
index f9a4085..df0a2a3 100755
--- a/pom.xml
+++ b/pom.xml
@@ -143,7 +143,6 @@
     <module>platforms</module>
     <module>tests</module>
     <module>examples</module>
-    <module>spring-boot-dm</module>
   </modules>
 
   <scm>

http://git-wip-us.apache.org/repos/asf/camel/blob/a15cbb47/spring-boot-dm/README.adoc
----------------------------------------------------------------------
diff --git a/spring-boot-dm/README.adoc b/spring-boot-dm/README.adoc
deleted file mode 100755
index 3af7326..0000000
--- a/spring-boot-dm/README.adoc
+++ /dev/null
@@ -1,46 +0,0 @@
-= Camel Spring-Boot Dependency Management
-
-The `spring-boot-dm` module include tools to generate a valid spring-boot BOM (bill of materials)
-that can be used in spring-boot applications.
-
-Using the generated BOM (`camel-spring-boot-dependencies`), together with the Spring framework's
`spring-boot-dependencies`,
- is the preferred way of configuring a Camel-based application running on Spring-Boot.
-
-The POM of a end user application should include both BOMs, as in the following example:
-
-[source,xml]
-.pom.xml
-----
-<?xml version="1.0" encoding="UTF-8"?>
-<project>
-  ...
-  <dependencyManagement>
-    <dependencies>
-      <dependency>
-        <groupId>org.springframework.boot</groupId>
-        <artifactId>spring-boot-dependencies</artifactId>
-        <version>${spring-boot-version}</version>
-        <type>pom</type>
-        <scope>import</scope>
-      </dependency>
-      <dependency>
-        <groupId>org.apache.camel</groupId>
-        <artifactId>camel-spring-boot-dependencies</artifactId>
-        <version>${project.version}</version>
-        <type>pom</type>
-        <scope>import</scope>
-      </dependency>
-    </dependencies>
-  </dependencyManagement>
-
-  <dependencies>
-    <!-- Include all needed camel-xxx-starter modules -->
-  </dependencies>
-
-  ...
-
-</project>
-----
-
-The `camel-spring-boot-dependencies` BOM includes Camel modules
-and all transitive dependencies that have no conflicts with the spring-boot BOM.
\ No newline at end of file


Mime
View raw message