camel-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From davscl...@apache.org
Subject [11/16] camel git commit: Make more camel-spring-xxx modules install in karaf.
Date Sat, 12 Mar 2016 14:37:29 GMT
Make more camel-spring-xxx modules install in karaf.


Project: http://git-wip-us.apache.org/repos/asf/camel/repo
Commit: http://git-wip-us.apache.org/repos/asf/camel/commit/7c77e185
Tree: http://git-wip-us.apache.org/repos/asf/camel/tree/7c77e185
Diff: http://git-wip-us.apache.org/repos/asf/camel/diff/7c77e185

Branch: refs/heads/master
Commit: 7c77e18566cd96f796501f3056488a0c9d13355d
Parents: 82d9b76
Author: Claus Ibsen <davsclaus@apache.org>
Authored: Sat Mar 12 14:15:44 2016 +0100
Committer: Claus Ibsen <davsclaus@apache.org>
Committed: Sat Mar 12 14:15:44 2016 +0100

----------------------------------------------------------------------
 components/camel-spring-ws/pom.xml              |  4 +-
 parent/pom.xml                                  | 12 +--
 .../features/src/main/resources/features.xml    | 82 ++++++++++----------
 3 files changed, 48 insertions(+), 50 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/camel/blob/7c77e185/components/camel-spring-ws/pom.xml
----------------------------------------------------------------------
diff --git a/components/camel-spring-ws/pom.xml b/components/camel-spring-ws/pom.xml
index a19ebd3..35b8fc2 100644
--- a/components/camel-spring-ws/pom.xml
+++ b/components/camel-spring-ws/pom.xml
@@ -33,8 +33,8 @@
 
   <properties>
     <camel.osgi.import.before.defaults>
-      org.springframework.beans.*;version="${spring4-version-range-karaf}",
-      org.springframework.util.*;version="${spring4-version-range-karaf}"
+      org.springframework.beans.*;version="${spring-version-range}",
+      org.springframework.util.*;version="${spring-version-range}"
     </camel.osgi.import.before.defaults>
     <camel.osgi.export.pkg>org.apache.camel.component.spring.ws.*</camel.osgi.export.pkg>
     <camel.osgi.export.service>org.apache.camel.spi.ComponentResolver;component=spring-ws</camel.osgi.export.service>

http://git-wip-us.apache.org/repos/asf/camel/blob/7c77e185/parent/pom.xml
----------------------------------------------------------------------
diff --git a/parent/pom.xml b/parent/pom.xml
index 613551a..70ee31d 100644
--- a/parent/pom.xml
+++ b/parent/pom.xml
@@ -490,8 +490,8 @@
     <spark-rest-version>2.3</spark-rest-version>
     <spark-rest-bundle-version>2.3_1</spark-rest-bundle-version>
     <splunk-version>1.5.0.0_1</splunk-version>
-    <spring-batch-version>3.0.4.RELEASE</spring-batch-version>
-    <spring-batch-bundle-version>3.0.4.RELEASE_1</spring-batch-bundle-version>
+    <spring-batch-version>3.0.6.RELEASE</spring-batch-version>
+    <spring-batch-bundle-version>3.0.6.RELEASE_1</spring-batch-bundle-version>
     <spring-boot-version>1.3.3.RELEASE</spring-boot-version>
     <spring-castor-bundle-version>1.2.0</spring-castor-bundle-version>
     <spring-data-commons-version>1.6.5.RELEASE</spring-data-commons-version>
@@ -503,11 +503,11 @@
     <!-- spring 1.1.0 is not OSGi bundle any more -->
     <spring-retry-version>1.0.3.RELEASE</spring-retry-version>
     <!-- spring-dm only supports spring 3.x -->
-    <spring-dm-version-range-karaf>[3.2,4)</spring-dm-version-range-karaf>
-    <!-- karaf 2.x supports spring 4.1 onwards -->
-    <spring-version-range-karaf>[4.1,5)</spring-version-range-karaf>
+    <spring-dm-version-range>[3.2,4)</spring-dm-version-range>
+    <!-- karaf 2.x/3.x/4.x supports spring 4.1 onwards -->
+    <spring-version-range>[4.1,5)</spring-version-range>
     <!-- and for spring 4.2.x onwards-->
-    <spring42-version-range-karaf>[4.2,5)</spring42-version-range-karaf>
+    <spring42-version-range>[4.2,5)</spring42-version-range>
     <spring-version>${spring4-version}</spring-version>
     <spring32-version>3.2.15.RELEASE</spring32-version>
     <spring40-version>4.0.9.RELEASE</spring40-version>

http://git-wip-us.apache.org/repos/asf/camel/blob/7c77e185/platforms/karaf/features/src/main/resources/features.xml
----------------------------------------------------------------------
diff --git a/platforms/karaf/features/src/main/resources/features.xml b/platforms/karaf/features/src/main/resources/features.xml
index 884882f..0173afc 100644
--- a/platforms/karaf/features/src/main/resources/features.xml
+++ b/platforms/karaf/features/src/main/resources/features.xml
@@ -28,9 +28,11 @@
     <bundle>mvn:org.codehaus.woodstox/woodstox-core-asl/${woodstox-version}</bundle>
     <bundle>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jaxb-impl/${jaxb-bundle-version}</bundle>
   </feature>
+
   <feature name='camel' version='${project.version}' resolver='(obr)' start-level='50'>
     <feature version='${project.version}'>camel-core</feature>
     <feature version='${project.version}'>camel-blueprint</feature>
+    <!-- we no longer install camel-spring by default as spring-dm is deprecated -->
   </feature>
   <feature name='camel-core' version='${project.version}' resolver='(obr)' start-level='50'>
     <feature version='${servicemix-specs-version}'>xml-specs-api</feature>
@@ -50,17 +52,24 @@
     <feature version='${project.version}'>camel-core</feature>
     <bundle>mvn:org.apache.camel.karaf/camel-karaf-commands-catalog/${project.version}</bundle>
   </feature>
+  <feature name='camel-blueprint' version='${project.version}' resolver='(obr)' start-level='50'>
+    <feature version='${project.version}'>camel-core</feature>
+    <bundle>mvn:org.apache.camel/camel-blueprint/${project.version}</bundle>
+  </feature>
   <feature name='camel-spring' version='${project.version}' resolver='(obr)' start-level='50'>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/${geronimo-jta-spec-version}</bundle>
-    <feature version='${spring-dm-version-range-karaf}'>spring</feature>
+    <feature version='${spring-dm-version-range}'>spring</feature>
     <feature version='[1.2,2)'>spring-dm</feature>
-    <feature version='${spring-dm-version-range-karaf}'>spring-tx</feature>
+    <feature version='${spring-dm-version-range}'>spring-tx</feature>
     <feature version='${project.version}'>camel-core</feature>
     <bundle>mvn:org.apache.camel/camel-spring/${project.version}</bundle>
   </feature>
-  <feature name='camel-blueprint' version='${project.version}' resolver='(obr)' start-level='50'>
-     <feature version='${project.version}'>camel-core</feature>
-     <bundle>mvn:org.apache.camel/camel-blueprint/${project.version}</bundle>
+  <feature name='camel-scr' version='${project.version}' resolver='(obr)' start-level='50'>
+    <feature version='${project.version}'>camel-core</feature>
+    <feature>scr</feature>
+    <feature>eventadmin</feature>
+    <bundle dependency='true'>mvn:org.apache.camel/camel-core-osgi/${project.version}</bundle>
+    <bundle>mvn:org.apache.camel/camel-scr/${project.version}</bundle>
   </feature>
 
   <!-- the following features are sorted A..Z -->
@@ -139,10 +148,10 @@
   </feature>
   <feature name='camel-bam' version='${project.version}' resolver='(obr)' start-level='50'>
     <feature version='${project.version}'>camel-core</feature>
-    <feature version='${spring-version-range-karaf}'>spring-orm</feature>
-    <feature version='${spring-version-range-karaf}'>spring-jdbc</feature>
-    <feature version='${spring-version-range-karaf}'>spring-tx</feature>
-    <feature version='${spring-version-range-karaf}'>spring-web</feature>
+    <feature version='${spring-version-range}'>spring-orm</feature>
+    <feature version='${spring-version-range}'>spring-jdbc</feature>
+    <feature version='${spring-version-range}'>spring-tx</feature>
+    <feature version='${spring-version-range}'>spring-web</feature>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/${geronimo-jta-spec-version}</bundle>
     <bundle dependency='true'>mvn:commons-pool/commons-pool/${commons-pool-version}</bundle>
     <bundle dependency='true'>mvn:commons-dbcp/commons-dbcp/${commons-dbcp-version}</bundle>
@@ -892,8 +901,8 @@
   </feature>
   <feature name='camel-jms' version='${project.version}' resolver='(obr)' start-level='50'>
     <feature version='${project.version}'>camel-core</feature>
-    <feature version='${spring-version-range-karaf}'>spring</feature>
-    <feature version='${spring-version-range-karaf}'>spring-jms</feature>
+    <feature version='${spring-version-range}'>spring</feature>
+    <feature version='${spring-version-range}'>spring-jms</feature>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/${geronimo-jta-spec-version}</bundle>
     <bundle dependency='true'>mvn:commons-pool/commons-pool/${commons-pool-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jms_1.1_spec/${geronimo-jms-spec-version}</bundle>
@@ -915,9 +924,9 @@
   </feature>
   <feature name='camel-jpa' version='${project.version}' resolver='(obr)' start-level='50'>
     <feature version='${project.version}'>camel-core</feature>
-    <feature version='${spring-version-range-karaf}'>spring-jdbc</feature>
-    <feature version='${spring-version-range-karaf}'>spring-orm</feature>
-    <feature version='${spring-version-range-karaf}'>spring-tx</feature>
+    <feature version='${spring-version-range}'>spring-jdbc</feature>
+    <feature version='${spring-version-range}'>spring-orm</feature>
+    <feature version='${spring-version-range}'>spring-tx</feature>
     <bundle dependency='true'> mvn:org.apache.geronimo.specs/geronimo-annotation_1.0_spec/${geronimo-annotation-1.0-spec-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jpa_2.0_spec/${geronimo-jpa2-spec-version}</bundle>
     <bundle dependency='true'>mvn:javax.servlet/javax.servlet-api/${javax.servlet-api-version}</bundle>
@@ -1127,11 +1136,6 @@
   </feature>
   <feature name='camel-mybatis' version='${project.version}' resolver='(obr)' start-level='50'>
     <feature version='${project.version}'>camel-core</feature>
-    <feature version='${project.version}'>camel-spring</feature>
-    <bundle dependency='true'>mvn:commons-pool/commons-pool/${commons-pool-version}</bundle>
-    <bundle dependency='true'>mvn:javax.servlet/javax.servlet-api/${javax.servlet-api-version}</bundle>
-    <bundle dependency='true'>mvn:commons-dbcp/commons-dbcp/${commons-dbcp-version}</bundle>
-    <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.cglib/${cglib-bundle-version}</bundle>
     <bundle dependency='true'>mvn:org.mybatis/mybatis/${mybatis-version}</bundle>
     <bundle>mvn:org.apache.camel/camel-mybatis/${project.version}</bundle>
   </feature>
@@ -1356,13 +1360,6 @@
     <bundle dependency='true'>mvn:commons-io/commons-io/${commons-io-version}</bundle>
     <bundle>mvn:org.apache.camel/camel-schematron/${project.version}</bundle>
   </feature>
-  <feature name='camel-scr' version='${project.version}' resolver='(obr)' start-level='50'>
-    <feature version='${project.version}'>camel-core</feature>
-    <feature>scr</feature>
-    <feature>eventadmin</feature>
-    <bundle dependency='true'>mvn:org.apache.camel/camel-core-osgi/${project.version}</bundle>
-    <bundle>mvn:org.apache.camel/camel-scr/${project.version}</bundle>
-  </feature>
    <feature name='camel-script-jruby' version='${project.version}' resolver='(obr)' start-level='50'>
     <feature version='${project.version}'>camel-script</feature>
     <bundle>mvn:com.google.code.scriptengines/scriptengines-jruby/${scriptengines-version}</bundle>
@@ -1475,7 +1472,9 @@
     <bundle>mvn:org.apache.camel/camel-splunk/${project.version}</bundle>
   </feature>
   <feature name='camel-spring-batch' version='${project.version}' resolver='(obr)' start-level='50'>
-    <feature version='${project.version}'>camel-spring</feature>
+    <feature>transaction</feature>
+    <feature version='${spring-version-range}'>spring</feature>
+    <feature version='${spring-version-range}'>spring-tx</feature>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jms_1.1_spec/${geronimo-jms-spec-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-batch-core/${spring-batch-bundle-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-batch-infrastructure/${spring-batch-bundle-version}</bundle>
@@ -1483,14 +1482,14 @@
   </feature>
   <feature name='camel-spring-javaconfig' version='${project.version}' resolver='(obr)'
start-level='50'>
     <feature version='${project.version}'>camel-spring</feature>
-    <feature version='${spring-version-range-karaf}'>spring-test</feature>
+    <feature version='${spring-version-range}'>spring-test</feature>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.cglib/${cglib-bundle-version}</bundle>
     <bundle>mvn:org.apache.camel/camel-spring-javaconfig/${project.version}</bundle>
   </feature>
   <feature name='camel-spring-ldap' version='${project.version}' resolver='(obr)' start-level='50'>
     <feature version='${project.version}'>camel-spring</feature>
-    <feature version='${spring-version-range-karaf}'>spring-tx</feature>
-    <feature version='${spring-version-range-karaf}'>spring-jdbc</feature>
+    <feature version='${spring-version-range}'>spring-tx</feature>
+    <feature version='${spring-version-range}'>spring-jdbc</feature>
     <bundle dependency='true'>mvn:commons-lang/commons-lang/${commons-lang-version}</bundle>
     <bundle dependency='true'>mvn:commons-pool/commons-pool/${commons-pool-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jms_1.1_spec/${geronimo-jms-spec-version}</bundle>
@@ -1503,8 +1502,8 @@
   <feature name='camel-spring-redis' version='${project.version}' resolver='(obr)' start-level='50'>
     <details>spring-data-redis doesn't support importing spring version which is above
4.0.5 </details>
     <feature version='${project.version}'>camel-core</feature>
-    <feature version='${spring-version-range-karaf}'>spring</feature>
-    <feature version='${spring-version-range-karaf}'>spring-tx</feature>
+    <feature version='${spring-version-range}'>spring</feature>
+    <feature version='${spring-version-range}'>spring-tx</feature>
     <bundle dependency='true'>mvn:commons-pool/commons-pool/${commons-pool-version}</bundle>
     <bundle dependency='true'>mvn:org.springframework.data/spring-data-redis/${spring-data-redis-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jedis/${jedis-client-bundle-version}</bundle>
@@ -1514,20 +1513,19 @@
   <feature name='camel-spring-security' version='${project.version}' resolver='(obr)'
start-level='50'>
     <details>spring-security doesn't support importing spring 4.x </details>
     <feature>http</feature>
-    <feature version='${spring-version-range-karaf}'>spring</feature>
-    <feature version='${spring-version-range-karaf}'>spring-web</feature>
+    <feature version='${spring-version-range}'>spring</feature>
+    <feature version='${spring-version-range}'>spring-web</feature>
     <bundle dependency='true'>mvn:org.springframework.security/spring-security-core/${spring-security-version}</bundle>
     <bundle dependency='true'>mvn:org.springframework.security/spring-security-config/${spring-security-version}</bundle>
     <bundle dependency='true'>mvn:org.springframework.security/spring-security-web/${spring-security-version}</bundle>
     <bundle>mvn:org.apache.camel/camel-spring-security/${project.version}</bundle>
   </feature>
   <feature name='camel-spring-ws' version='${project.version}' resolver='(obr)' start-level='50'>
-    <details>camel-spring-ws requires spring 4.x</details>
     <feature>http</feature>
-    <feature version='${spring4-version-range-karaf}'>spring</feature>
-    <feature version='${spring4-version-range-karaf}'>spring-jms</feature>
-    <feature version='${spring4-version-range-karaf}'>spring-oxm</feature>
-    <feature version='${spring4-version-range-karaf}'>spring-web</feature>
+    <feature version='${spring-version-range}'>spring</feature>
+    <feature version='${spring-version-range}'>spring-jms</feature>
+    <feature version='${spring-version-range}'>spring-oxm</feature>
+    <feature version='${spring-version-range}'>spring-web</feature>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jms_1.1_spec/${geronimo-jms-spec-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.wsdl4j/${wsdl4j-bundle-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-ws-core/${spring-ws-bundle-version}</bundle>
@@ -1538,8 +1536,8 @@
   </feature>
   <feature name='camel-sql' version='${project.version}' resolver='(obr)' start-level='50'>
     <feature version='${project.version}'>camel-core</feature>
-    <feature version='${spring-version-range-karaf}'>spring-tx</feature>
-    <feature version='${spring-version-range-karaf}'>spring-jdbc</feature>
+    <feature version='${spring-version-range}'>spring-tx</feature>
+    <feature version='${spring-version-range}'>spring-jdbc</feature>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/${geronimo-jta-spec-version}</bundle>
     <bundle>mvn:org.apache.camel/camel-sql/${project.version}</bundle>
   </feature>
@@ -1646,7 +1644,7 @@
   </feature>
   <feature name='camel-test-spring' version='${project.version}' resolver='(obr)' start-level='50'>
     <feature version='${project.version}'>camel-spring</feature>
-    <feature version='${spring-version-range-karaf}'>spring-test</feature>
+    <feature version='${spring-version-range}'>spring-test</feature>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.junit/${junit-bundle-version}</bundle>
     <bundle>mvn:org.apache.camel/camel-test/${project.version}</bundle>
     <bundle>mvn:org.apache.camel/camel-test-spring/${project.version}</bundle>


Mime
View raw message