camel-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From build...@apache.org
Subject svn commit: r922277 - in /websites/production/camel/content: cache/main.pageCache karaf.html
Date Mon, 15 Sep 2014 13:18:03 GMT
Author: buildbot
Date: Mon Sep 15 13:18:02 2014
New Revision: 922277

Log:
Production update by buildbot for camel

Modified:
    websites/production/camel/content/cache/main.pageCache
    websites/production/camel/content/karaf.html

Modified: websites/production/camel/content/cache/main.pageCache
==============================================================================
Binary files - no diff available.

Modified: websites/production/camel/content/karaf.html
==============================================================================
--- websites/production/camel/content/karaf.html (original)
+++ websites/production/camel/content/karaf.html Mon Sep 15 13:18:02 2014
@@ -84,7 +84,7 @@
 	<tbody>
         <tr>
         <td valign="top" width="100%">
-<div class="wiki-content maincontent"><h2 id="Karaf-KarafSupport">Karaf Support</h2><p>Apache
Camel is designed to work nicely into <a shape="rect" class="external-link" href="http://karaf.apache.org">Apache
Karaf</a> OSGi container.</p><p>It includes:</p><ul><li>Camel
features descriptor allowing to easily and quickly install Camel in Karaf.</li><li>Karaf
commands allowing you to view, start, stop, get info, about the Camel contexts and routes
running in the Karaf instance.<br clear="none"> <strong>NB: Karaf commands are
available starting with Camel 2.8.0</strong>, and the commands was renamed in Camel
2.9.0.</li></ul><p>Here are the versions that are compatible.</p><div
class="table-wrap"><table class="confluenceTable"><tbody><tr><th colspan="1"
rowspan="1" class="confluenceTh"><p>Camel Version</p></th><th colspan="1"
rowspan="1" class="confluenceTh"><p>Karaf Version</p></th></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.2.0</p></td><td
colspan="1" rowspan="1" cla
 ss="confluenceTd"><p>1.2.0</p></td></tr><tr><td colspan="1"
rowspan="1" class="confluenceTd"><p>2.3.0</p></td><td colspan="1"
rowspan="1" class="confluenceTd"><p>1.3.0</p></td></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.4.0</p></td><td
colspan="1" rowspan="1" class="confluenceTd"><p>1.4.0</p></td></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.5.0</p></td><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.1.0</p></td></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.7.0</p></td><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.2.0</p></td></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.7.2</p></td><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.2.2</p></td></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.8.2</p></td><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.2.4</p></td></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.9.0</p></td><td
colspan="1" rowspan="1" class="conflu
 enceTd"><p>2.2.5</p></td></tr><tr><td colspan="1" rowspan="1"
class="confluenceTd"><p>2.10.0</p></td><td colspan="1" rowspan="1"
class="confluenceTd"><p>2.2.8</p></td></tr><tr><td colspan="1"
rowspan="1" class="confluenceTd"><p>2.11.0</p></td><td colspan="1"
rowspan="1" class="confluenceTd"><p>2.3.1</p></td></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.12.0</p></td><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.3.2</p></td></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd">2.13.0</td><td colspan="1" rowspan="1"
class="confluenceTd">2.3.3</td></tr></tbody></table></div><h2
id="Karaf-PreparingKarafforCamel">Preparing Karaf for Camel</h2><p>Camel uses
several bundles to provide low level package, such as javax.annotation or javax.xml.bind.</p><p>Due
to that, we mustn't use the default system package coming from the JDK. It means that we need
to "exclude" some packages from system packages in order to use packages provided by tiers
bundles.</p><p>Camel pro
 vides a ready to use config.properties file that you can download:</p><p><a
shape="rect" class="external-link" href="http://svn.apache.org/repos/asf/camel/tags/camel-2.7.2/platforms/karaf/features/src/main/resources/config.properties">http://svn.apache.org/repos/asf/camel/tags/camel-2.7.2/platforms/karaf/features/src/main/resources/config.properties</a></p><p>This
file has to be copied into Karaf etc folder.</p>    <div class="aui-message hint
shadowed information-macro">
+<div class="wiki-content maincontent"><h2 id="Karaf-KarafSupport">Karaf Support</h2><p>Apache
Camel is designed to work nicely into <a shape="rect" class="external-link" href="http://karaf.apache.org">Apache
Karaf</a> OSGi container.</p><p>It includes:</p><ul><li>Camel
features descriptor allowing to easily and quickly install Camel in Karaf.</li><li>Karaf
commands allowing you to view, start, stop, get info, about the Camel contexts and routes
running in the Karaf instance.<br clear="none"> <strong>NB: Karaf commands are
available starting with Camel 2.8.0</strong>, and the commands was renamed in Camel
2.9.0.</li></ul><p>Here are the versions that are compatible.</p><div
class="table-wrap"><table class="confluenceTable"><tbody><tr><th colspan="1"
rowspan="1" class="confluenceTh"><p>Camel Version</p></th><th colspan="1"
rowspan="1" class="confluenceTh"><p>Karaf Version</p></th></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.2.0</p></td><td
colspan="1" rowspan="1" cla
 ss="confluenceTd"><p>1.2.0</p></td></tr><tr><td colspan="1"
rowspan="1" class="confluenceTd"><p>2.3.0</p></td><td colspan="1"
rowspan="1" class="confluenceTd"><p>1.3.0</p></td></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.4.0</p></td><td
colspan="1" rowspan="1" class="confluenceTd"><p>1.4.0</p></td></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.5.0</p></td><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.1.0</p></td></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.7.0</p></td><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.2.0</p></td></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.7.2</p></td><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.2.2</p></td></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.8.2</p></td><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.2.4</p></td></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.9.0</p></td><td
colspan="1" rowspan="1" class="conflu
 enceTd"><p>2.2.5</p></td></tr><tr><td colspan="1" rowspan="1"
class="confluenceTd"><p>2.10.0</p></td><td colspan="1" rowspan="1"
class="confluenceTd"><p>2.2.8</p></td></tr><tr><td colspan="1"
rowspan="1" class="confluenceTd"><p>2.11.0</p></td><td colspan="1"
rowspan="1" class="confluenceTd"><p>2.3.1</p></td></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.12.0</p></td><td
colspan="1" rowspan="1" class="confluenceTd"><p>2.3.2</p></td></tr><tr><td
colspan="1" rowspan="1" class="confluenceTd">2.13.0</td><td colspan="1" rowspan="1"
class="confluenceTd">2.3.3</td></tr><tr><td colspan="1" rowspan="1"
class="confluenceTd">2.14.0</td><td colspan="1" rowspan="1" class="confluenceTd">2.3.7</td></tr></tbody></table></div><h2
id="Karaf-PreparingKarafforCamel">Preparing Karaf for Camel</h2><p>Camel uses
several bundles to provide low level package, such as javax.annotation or javax.xml.bind.</p><p>Due
to that, we mustn't use the default system package coming from the JDK. It means 
 that we need to "exclude" some packages from system packages in order to use packages provided
by tiers bundles.</p><p>Camel provides a ready to use config.properties file that
you can download:</p><p><a shape="rect" class="external-link" href="http://svn.apache.org/repos/asf/camel/tags/camel-2.7.2/platforms/karaf/features/src/main/resources/config.properties">http://svn.apache.org/repos/asf/camel/tags/camel-2.7.2/platforms/karaf/features/src/main/resources/config.properties</a></p><p>This
file has to be copied into Karaf etc folder.</p>    <div class="aui-message hint
shadowed information-macro">
                     <p class="title">Karaf 2.2.5 or newer</p>
                             <span class="aui-icon icon-hint">Icon</span>
                 <div class="message-content">



Mime
View raw message