camel-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From davscl...@apache.org
Subject [1/2] git commit: CAMEL-7267: Error install camel-salesforce in karaf if joda-time 1.x has been installed already. Need to open up the import version range.
Date Tue, 04 Mar 2014 13:40:33 GMT
Repository: camel
Updated Branches:
  refs/heads/camel-2.12.x fca886e36 -> 90daf3818
  refs/heads/master b6ee9c91e -> 738b6097f


CAMEL-7267: Error install camel-salesforce in karaf if joda-time 1.x has been installed already.
Need to open up the import version range.


Project: http://git-wip-us.apache.org/repos/asf/camel/repo
Commit: http://git-wip-us.apache.org/repos/asf/camel/commit/738b6097
Tree: http://git-wip-us.apache.org/repos/asf/camel/tree/738b6097
Diff: http://git-wip-us.apache.org/repos/asf/camel/diff/738b6097

Branch: refs/heads/master
Commit: 738b6097fbe4db00f31dbe3ca18c15cb5a34adb0
Parents: b6ee9c9
Author: Claus Ibsen <davsclaus@apache.org>
Authored: Tue Mar 4 14:41:07 2014 +0100
Committer: Claus Ibsen <davsclaus@apache.org>
Committed: Tue Mar 4 14:41:07 2014 +0100

----------------------------------------------------------------------
 components/camel-salesforce/camel-salesforce-component/pom.xml | 3 +++
 1 file changed, 3 insertions(+)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/camel/blob/738b6097/components/camel-salesforce/camel-salesforce-component/pom.xml
----------------------------------------------------------------------
diff --git a/components/camel-salesforce/camel-salesforce-component/pom.xml b/components/camel-salesforce/camel-salesforce-component/pom.xml
index 66165a1..011cb52 100644
--- a/components/camel-salesforce/camel-salesforce-component/pom.xml
+++ b/components/camel-salesforce/camel-salesforce-component/pom.xml
@@ -31,6 +31,9 @@
   <description>Camel Salesforce support</description>
 
   <properties>
+    <camel.osgi.import.before.defaults>
+        org.joda.time.*;version="[1.6,3)"
+    </camel.osgi.import.before.defaults>
     <camel.osgi.export.pkg>
       org.apache.camel.component.salesforce,
       org.apache.camel.component.salesforce.api.*


Mime
View raw message