camel-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From davscl...@apache.org
Subject svn commit: r1435239 - in /camel/trunk: parent/pom.xml platforms/karaf/features/src/main/resources/features.xml
Date Fri, 18 Jan 2013 16:41:37 GMT
Author: davsclaus
Date: Fri Jan 18 16:41:37 2013
New Revision: 1435239

URL: http://svn.apache.org/viewvc?rev=1435239&view=rev
Log:
CAMEL-5931: Camel Karaf features is requiring Spring 3.1 version. Use spring-version-range
so we can adjust this easier in the future.

Modified:
    camel/trunk/parent/pom.xml
    camel/trunk/platforms/karaf/features/src/main/resources/features.xml

Modified: camel/trunk/parent/pom.xml
URL: http://svn.apache.org/viewvc/camel/trunk/parent/pom.xml?rev=1435239&r1=1435238&r2=1435239&view=diff
==============================================================================
--- camel/trunk/parent/pom.xml (original)
+++ camel/trunk/parent/pom.xml Fri Jan 18 16:41:37 2013
@@ -334,14 +334,15 @@
     <spring-neo4j-version>2.1.0.RELEASE</spring-neo4j-version>
     <spring-retry-version>1.0.2.RELEASE</spring-retry-version>
     <!-- CAMEL-5768 using spring3.1.x by default -->
+    <spring-version-range>[3.1,3.2)</spring-version-range>
     <spring-version>${spring31-version}</spring-version>
+    <!-- spring 3.0 support is @deprecated -->
     <spring30-version>3.0.7.RELEASE</spring30-version>
     <spring31-version>3.1.3.RELEASE</spring31-version>
     <spring32-version>3.2.0.RELEASE</spring32-version>
     <spring-osgi-version>1.2.1</spring-osgi-version>
     <spring-security-version>3.1.3.RELEASE</spring-security-version>
-    <!-- spring WS 2.0.3 is the last release to support Spring 3.0.x -->
-    <spring-ws-version>2.0.3.RELEASE</spring-ws-version>
+    <spring-ws-version>2.1.2.RELEASE</spring-ws-version>
     <spymemcached-bundle-version>2.5_2</spymemcached-bundle-version> <!--
FIXME cmueller: not in sync! -->
     <spymemcached-version>2.8.4</spymemcached-version>
     <sshd-version>0.8.0</sshd-version>
@@ -397,7 +398,7 @@
     <camel.osgi.import.defaults>
       org.springframework.ws.*;version="[2,3)",
       org.springframework.xml.*;version="[2,3)",
-      org.springframework.*;version="[3,4)",
+      org.springframework.*;version="${spring-version-range}",
       org.apache.commons.logging.*;version="[1.1,2)",
       org.apache.cxf.*;version="${cxf-version-range}",
       org.apache.qpid.*;version="[0.14,1)",

Modified: camel/trunk/platforms/karaf/features/src/main/resources/features.xml
URL: http://svn.apache.org/viewvc/camel/trunk/platforms/karaf/features/src/main/resources/features.xml?rev=1435239&r1=1435238&r2=1435239&view=diff
==============================================================================
--- camel/trunk/platforms/karaf/features/src/main/resources/features.xml (original)
+++ camel/trunk/platforms/karaf/features/src/main/resources/features.xml Fri Jan 18 16:41:37
2013
@@ -40,9 +40,9 @@
   </feature>
   <feature name='camel-spring' version='${project.version}' resolver='(obr)' start-level='50'>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/${geronimo-jta-spec-version}</bundle>
-    <feature version='[3,4)'>spring</feature>
+    <feature version='${spring-version-range}'>spring</feature>
     <feature version='[1.2,2)'>spring-dm</feature>
-    <feature version='[3,4)'>spring-tx</feature>
+    <feature version='${spring-version-range}'>spring-tx</feature>
     <feature version='${project.version}'>camel-core</feature>
     <bundle>mvn:org.apache.camel/camel-spring/${project.version}</bundle>
   </feature>
@@ -154,11 +154,11 @@
     <bundle>mvn:org.apache.camel/camel-servlet/${project.version}</bundle>
   </feature>
   <feature name='camel-jms' version='${project.version}' resolver='(obr)' start-level='50'>
-    <feature version='[3,4)'>spring</feature>
+    <feature version='${spring-version-range}'>spring</feature>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/${geronimo-jta-spec-version}</bundle>
     <bundle dependency='true'>mvn:commons-pool/commons-pool/${commons-pool-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jms_1.1_spec/${geronimo-jms-spec-version}</bundle>
-    <feature version='[3,4)'>spring-jms</feature>
+    <feature version='${spring-version-range}'>spring-jms</feature>
     <feature version='${project.version}'>camel-core</feature>
     <bundle>mvn:org.apache.camel/camel-jms/${project.version}</bundle>
   </feature>
@@ -223,10 +223,10 @@
     <bundle>mvn:org.apache.camel/camel-avro/${project.version}</bundle>
   </feature>
   <feature name='camel-bam' version='${project.version}' resolver='(obr)' start-level='50'>
-    <feature version='[3,4)'>spring-tx</feature>
-    <feature version='[3,4)'>spring-web</feature>
+    <feature version='${spring-version-range}'>spring-tx</feature>
+    <feature version='${spring-version-range}'>spring-web</feature>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/${geronimo-jta-spec-version}</bundle>
-    <feature version='[3,4)'>spring-jdbc</feature>
+    <feature version='${spring-version-range}'>spring-jdbc</feature>
     <bundle dependency='true'>mvn:commons-pool/commons-pool/${commons-pool-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.commons-dbcp/${commons-dbcp-bundle-version}</bundle>
     <bundle dependency='true'>mvn:commons-lang/commons-lang/${commons-lang-version}</bundle>
@@ -235,7 +235,7 @@
     <bundle dependency='true'>mvn:org.apache.servicemix.specs/org.apache.servicemix.specs.java-persistence-api-1.1.1/${servicemix-specs-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.oscache/${oscache-bundle-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.ibatis-sqlmap/${ibatis-bundle-version}</bundle>
-    <feature version='[3,4)'>spring-orm</feature>
+    <feature version='${spring-version-range}'>spring-orm</feature>
     <feature version='${project.version}'>camel-core</feature>
     <bundle>mvn:org.apache.camel/camel-bam/${project.version}</bundle>
   </feature>
@@ -539,10 +539,10 @@
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-annotation_1.0_spec/${geronimo-annotation-spec-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jpa_2.0_spec/${geronimo-jpa2-spec-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-servlet_2.5_spec/${geronimo-servlet-spec-version}</bundle>
-    <feature version='[3,4)'>spring-tx</feature>
+    <feature version='${spring-version-range}'>spring-tx</feature>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-el_1.0_spec/${geronimo-el-spec-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/${geronimo-jta-spec-version}</bundle>
-    <feature version='[3,4)'>spring-jdbc</feature>
+    <feature version='${spring-version-range}'>spring-jdbc</feature>
     <bundle dependency='true'>mvn:commons-lang/commons-lang/${commons-lang-version}</bundle>
     <bundle dependency='true'>mvn:commons-collections/commons-collections/${commons-collections-version}</bundle>
     <bundle dependency='true'>mvn:commons-pool/commons-pool/${commons-pool-version}</bundle>
@@ -552,7 +552,7 @@
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jms_1.1_spec/${geronimo-jms-spec-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.asm/${asm-bundle-version}</bundle>
     <bundle>mvn:org.apache.openjpa/openjpa/${openjpa-version}</bundle>
-    <feature version='[3,4)'>spring-orm</feature>
+    <feature version='${spring-version-range}'>spring-orm</feature>
     <feature version='${project.version}'>camel-core</feature>
     <bundle>mvn:org.apache.camel/camel-jpa/${project.version}</bundle>
   </feature>
@@ -812,13 +812,13 @@
   <feature name='camel-spring-javaconfig' version='${project.version}' resolver='(obr)'
start-level='50'>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.cglib/${cglib-bundle-version}</bundle>
     <feature version='${project.version}'>camel-spring</feature>
-    <feature version='[3,4)'>spring-test</feature>
+    <feature version='${spring-version-range}'>spring-test</feature>
     <bundle>mvn:org.apache.camel/camel-spring-javaconfig/${project.version}</bundle>
   </feature>
   <feature name='camel-spring-security' version='${project.version}' resolver='(obr)'
start-level='50'>
     <feature>http</feature>
     <feature version='${project.version}'>camel-spring</feature>
-    <feature version='[3,4)'>spring-web</feature>
+    <feature version='${spring-version-range}'>spring-web</feature>
     <bundle dependency='true'>mvn:org.springframework.security/spring-security-core/${spring-security-version}</bundle>
     <bundle dependency='true'>mvn:org.springframework.security/spring-security-config/${spring-security-version}</bundle>
     <bundle dependency='true'>mvn:org.springframework.security/spring-security-web/${spring-security-version}</bundle>
@@ -830,18 +830,18 @@
     <bundle dependency='true'>mvn:javax.mail/mail/${javax-mail-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jms_1.1_spec/${geronimo-jms-spec-version}</bundle>
     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.smack/${smack-bundle-version}</bundle>
-    <feature version='[3,4)'>spring-jms</feature>
-    <feature version='[3,4)'>spring-web</feature>
-    <feature version='[3,4)'>spring-oxm</feature>
+    <feature version='${spring-version-range}'>spring-jms</feature>
+    <feature version='${spring-version-range}'>spring-web</feature>
+    <feature version='${spring-version-range}'>spring-oxm</feature>
     <bundle dependency='true'>mvn:org.springframework.ws/spring-xml/${spring-ws-version}</bundle>
     <bundle dependency='true'>mvn:org.springframework.ws/spring-ws-core/${spring-ws-version}</bundle>
     <bundle dependency='true'>mvn:org.springframework.ws/spring-ws-support/${spring-ws-version}</bundle>
     <bundle>mvn:org.apache.camel/camel-spring-ws/${project.version}</bundle>
   </feature>
   <feature name='camel-sql' version='${project.version}' resolver='(obr)' start-level='50'>
-    <feature version='[3,4)'>spring-tx</feature>
+    <feature version='${spring-version-range}'>spring-tx</feature>
     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/${geronimo-jta-spec-version}</bundle>
-    <feature version='[3,4)'>spring-jdbc</feature>
+    <feature version='${spring-version-range}'>spring-jdbc</feature>
     <feature version='${project.version}'>camel-core</feature>
     <bundle>mvn:org.apache.camel/camel-sql/${project.version}</bundle>
   </feature>



Mime
View raw message